0
$\begingroup$

Rosanswers logo

Hi there,

I have written a simple serviceClient subscriber to Vicon_bridge services. Basically, I want to have a clent that retrieves the pose information from the vicon_bridge Service Server.

I have tried all I know but every time I run the code, the error condition returns as so:

[ INFO] [1448305105.714274705]: waitForService: Service [/vicon/Superchicko/headcore] has not been advertised, waiting...

even though the vicon_bridge node is clearly advertising since

rostopic echo /vicon_bridge/Superchicko/headCore

does show me the pose messages in another terminal.

I see on the roscpp documentation page that when subscribing to a ServiceServer within a class, the Service client should be constructed as follows:

ServiceClient ros::NodeHandle::serviceClient ( const std::string & service_name, bool persistent = false, const M_string & header_values = M_string() )

The thing is when I try this, I get no calls either from the vicon_bridge::viconGrabPose. Could anyone help me out?


Originally posted by lakehanne on ROS Answers with karma: 152 on 2015-11-23

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It's fixed. Code is available on my page.

The service server is advertised as "/vicon/grab_vicon_pose/" and not vicon/subject_name/segment_name.

My bad!


Originally posted by lakehanne with karma: 152 on 2015-11-23

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.