0
$\begingroup$

Rosanswers logo

i've started the leg_detector and the urg_node with a launch file:

<launch>
  <node pkg="leg_detector" type="leg_detector" name="leg_detector" args="scan:=scan $(find leg_detector)/config/trained_leg_detector.yaml" output="screen"/>
  <node name="urg_node" pkg="urg_node" type="urg_node" output="screen" args="/most_intense:=/scan">
            <param name="ip_address" value="192.168.0.10"/> 
            <param name="frame_id" value="base_laser"/> 
  </node>
</launch>

How can start the leg detection right and how can i visualize them in rviz? i can see with rostopic echo /scan that the urg_node is publishing the measures and i can visualize them in rviz. The visualization_marker from leg_detector doesn't publish anything.

i get the warning in the console:

[ WARN] [1448009011.893469224]: MessageFilter [target=odom_combined ]: Dropped 100.00% of messages so far. Please turn the [ros.leg_detector.message_notifier] rosconsole logger to DEBUG for more information.

Thanks in advance


Originally posted by kkalicki on ROS Answers with karma: 13 on 2015-11-18

Post score: 1


Original comments

Comment by David Lu on 2015-11-19:
Is there any output in the console? Does rostopic info scan show the nodes are properly connected?

Comment by kkalicki on 2015-11-20:
I see the urg_node as publisher and the leg_detector as subscriber. I get the Warning: MessageFilter [target=odom_combined ]: Dropped 100.00% of messages so far. Please turn the [ros.leg_detector.message_notifier] rosconsole logger to DEBUG for more information.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Change the fixed_frame parameter to reflect the real name of your odometry tf frame. In my case that was just odom. Please have a look at your tf treet to find the frame you want. You can then change it using dynamic reconfigure or just add it in the launch file:

<node pkg="leg_detector" type="leg_detector" name="leg_detector" args="scan:=scan $(find leg_detector)/config/trained_leg_detector.yaml" output="screen">
    <param name="fixed_frame" type="string" value="odom" />
</node>

If you don't have an odometry frame just use the one of the laser and see if that works for you.


Originally posted by Chrissi with karma: 1642 on 2015-11-20

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by kkalicki on 2015-11-27:
Thank you, had to change the fixed_frame from leg_detector to the frame_id from the urg_node

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.