0
$\begingroup$

Rosanswers logo

Hello,

I want to combine a razor 9dof IMU (package razor_imu_9dof) with visual odometry from ASUS Xtion Pro live using rtabmap. I used package robot_localization to combine 2 data sources. I am confusing about the tf. I still use the visual odometry from rtabmap_ros. The package robot_localization takes data from topic /imu and /rtabmap/odom. In theory the tf from odom to camera_link must be published by robot_localization but it is still published by /rtabmap/rgbd_odometry. Can anyone explain me about the tf which is published by rtabmap/rgbd_odometry and the tf which is published by robot_localization and how to fix my problem or show me how to do the combination, please?

Another question is that when rtabmap/rtabmapviz doesn't subcribe any odometry topic, i still receive the map data, the rtabmapviz gui seems to work well. The only unusual thing is that the odometry display in rtabmapviz gui is black. It made me think the odometry is not important or i misunderstand something? Can anyone explain me, please?

I attached here the TFTree and NodeGraph.

Thank you in advance for your attention to this matter.

TF Tree http://s14.postimg.org/mtz02ccpd/frames.png Node Graph http://s7.postimg.org/arsi06e7f/rosgraph.png


Originally posted by VMHOANG68 on ROS Answers with karma: 33 on 2015-11-18

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You should set publish_tf parameter of rgbd_odometry node to false.

<node package="rtabmap_ros" type="rgbd_odometry" name="rgbd_odomerty">
   <param name="publish_tf" type="bool" value="false"/>
   ...
</node>

Odometry topic is mandatory for rtabmap, not for rtabmapviz. The odometry topic is used by rtabmap only if odom_frame_id parameter is set:

~odom_frame_id (string, default: "")

The frame attached to odometry. If empty, rtabmap will subscribe to odom topic to get odometry. If set, odometry is got from tf (in this case, a covariance of 1 is used).

cheers


Originally posted by matlabbe with karma: 6409 on 2015-11-18

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by VMHOANG68 on 2015-11-18:
Thank you matlabbe, now it is working as I desired.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.