0
$\begingroup$

Rosanswers logo

Hello, i had this strange error. a few days ago, i've succeed catkin_make and roslaunch skeleton_markers skeleton.launch . so the program successfully running. But, because of i have some error code for my other package on my workspace, someone said that i have to delete the 'build' folder in my workspace and re build my package, but i accidentally delete (with SHIFT+DEL) my install folder (which is source of my install/setup.bash). --this is my stupid accident-- after that, i remake my install folder by catkin_make install in my workspace folder with source in my devel/setup.bash and rebuild with catkin_make, and change again my source to install/setup.bash, and rebuild again with catkin_make.

but still, the result is said that :

 [skeleton.launch] is neither a launch file in package [skeleton_markers] nor is [skeleton_markers] a launch file

i've done re-package my package folder by catkin_create-pkg, but the result still same. i don't know anymore what i have to do with this. please help me :"(

oh, and it's not only that package which have error, but i think all my package inside my workspace can't be launched :( i can find my rospackage with rospack find <package>


Originally posted by adelleodel on ROS Answers with karma: 76 on 2015-11-12

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I think the best way you should follow is backing up your packages, deleting your catkin workspace and creating your workspace again with catkin_init_workspace . After you can put your packages back and run catkin_make. Do not forget to source your devel/setup.bash in your .bashrc file or running source /home/<username>/<catkin_ws>/devel/setup.bash in your terminal.

UPDATE

In your .bashrc, you should have:

source /opt/ros/indigo/setup.bash
source ~/ros/devel/setup.bash

Also, seems like your ROS_PACKAGE_PATH variable is outdated. In your terminal, can you run;

export ROS_PACKAGE_PATH=/home/adelleodel/ros/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks

Originally posted by Akif with karma: 3561 on 2015-11-12

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by adelleodel on 2015-11-12:
I've try it for devel/setup.bash before.. and i hv problem with openni library (problem when catkin_make) that can't find openni package though the file was there, and the problem solved by changing my source to install/setup.bash (i don't know why). But i'll try again with ROS_PACKAGE_PATH update

Comment by adelleodel on 2015-11-12:
Yeah, i succesfully can launch one of my packages. But, i still have another packages that still stuck in my old workspace path. It still respond same error, and when i rospack find package, it said that /home/adelleodel/rosadel/install/share/my_package what to do?

Comment by adelleodel on 2015-11-12:
Ahhh it seems that i haven't move that package /lol Thankyou so much for your help Akif!!! ^^

Comment by Akif on 2015-11-12:
I'm glad you figured it out!

Comment by Alan8 on 2019-06-28:
I get this error all the time! What a flaky system! Sourcing setup.bash fixes it SOMETIMES. It's not working now.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.