0
$\begingroup$

Rosanswers logo

Hi,

I am trying to setup the Arduino IDE according to the tutorial -> http://wiki.ros.org/rosserial_arduino/Tutorials/Arduino%20IDE%20Setup However, I ran into this problem at the last step where i run the following command.

rosrun rosserial_arduino make_libraries.py .

At the terminal, I received the result below. Any insight on what caused this and how to fix this? Thank you.

 *** Warning, failed to generate libraries for the following packages: ***
    urdf_tutorial (missing dependency: convex_decomposition)
Traceback (most recent call last):
  File "/home/user/catkin_ws/install/share/rosserial_arduino/make_libraries.py", line 91, in <module>
    rosserial_generate(rospack, path+"/ros_lib", ROS_TO_EMBEDDED_TYPES)
  File "/home/user/catkin_ws/install/lib/python2.7/dist-packages/rosserial_client/make_library.py", line 584, in rosserial_generate
    raise Exception("Failed to generate libraries for: " + str(failed))
Exception: Failed to generate libraries for: ['urdf_tutorial (missing dependency: convex_decomposition)']

Originally posted by Kiroja on ROS Answers with karma: 1 on 2015-10-04

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

under ubuntu: sudo apt-get install ros-jade-convex-decomposition


Originally posted by mimooh with karma: 36 on 2015-10-12

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.