Rosanswers logo

Hello, I am trying to upgrade from ros indigo to ros jade. I followed the following procedure

sudo apt-get get remove ros-indigo-desktop-full


sudo apt-get get install ros-jade-desktop-full

However, when I am trying to launch a simulation with gazebo I obtain the following error

/opt/ros/jade/lib/gazebo_ros/gzserver: 22: .: Can't open /share/gazebo//setup.sh

/opt/ros/jade/lib/gazebo_ros/gzclient: 17: .: Can't open /share/gazebo//setup.sh

[gazebo-2] process has died [pid 5171, exit code 2, cmd /opt/ros/jade/lib/gazebo_ros/gzserver -e ode /home/mago/Projects/2015a_Nicastro_HeterogeneousMultirobot/src/uav/worlds/vtol.world __name:=gazebo __log:=/home/mago/.ros/log/0b588c00-6078-11e5-b34f-f04da268d7ae/gazebo-2.log]. log file: /home/mago/.ros/log/0b588c00-6078-11e5-b34f-f04da268d7ae/gazebo-2*.log

Apparently it can't find the file /share/gazebo//setup.sh
I noticed the double slash, therefore I tried to search the setup.sh file manually. However, the command

ls /usr/share/ | grep gazebo




Moreover, in the "gazebo-5.0" folder there is no file "setup.sh"

I think something went wrong during the installation, I tried to remove everything and reinstall but without success. Can anyone help me?

EDIT: I tried the workaround described here, but apparently I have libgazebo5-dev already installed.

Originally posted by Mago Nick on ROS Answers with karma: 385 on 2015-09-21

Post score: 2


1 Answer 1


Rosanswers logo

Hi, installing the gazebo5 package seems to have solved the problem. However I do not understand why this was necessary. Isn't the package ros-jade-desktop-full supposed to install it?

Thank anyway


Originally posted by Mago Nick with karma: 385 on 2015-09-22

This answer was ACCEPTED on the original site

Post score: 3

Original comments

Comment by Markus Bader on 2015-10-09:
Hi, i had the same problem sudo apt-get install gazebo5 solved it :-)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.