0
$\begingroup$

Rosanswers logo

Hi.

I am trying to install ROS Indigo on Ubuntu 14.04.03, but i keep getting this error message (for all the other install packages aswell)

E: Unable to locate package ros-indigo-desktop-full

I found several similar questions about this, but they all dated back to earlier this year. Some of them stated that indigo was not released for 14.04.03 yet, and that this release would come in May this year.

Since it is well past may, i was hoping someone had some insight as to why this is still not working?

Cheers

*edit: adding that i have followed this install tutorial to the point. http://wiki.ros.org/indigo/Installation/Ubuntu

I have also tried the dependency fix mentioned there, for 14.04.2, which just gave a lot more error messages about missing several other packages.

Can also add that i have installed ROS Jade without any problems at all, so there is nothing wrong with my Ubuntu distr (as far as i can tell).

**edit for new info:

$ cat /etc/apt/sources.list.d/ros-latest.list
deb http://packages.ros.org/ros/ubuntu vivid main

$ sudo apt-get update
Ign http://dl.google.com stable InRelease
Ign http://archive.canonical.com vivid InRelease                                    
Ign http://no.archive.ubuntu.com vivid InRelease                                    
Hit http://dl.google.com stable Release.gpg                                         
Ign http://no.archive.ubuntu.com vivid-updates InRelease                            
Hit http://archive.canonical.com vivid Release.gpg                                  
Hit http://dl.google.com stable Release                                             
Ign http://no.archive.ubuntu.com vivid-backports InRelease                          
Hit http://dl.google.com stable/main amd64 Packages                                 
Hit http://archive.canonical.com vivid Release                                      
Hit http://no.archive.ubuntu.com vivid Release.gpg                                  
Get:1 http://no.archive.ubuntu.com vivid-updates Release.gpg [933 B]                
Hit http://dl.google.com stable/main i386 Packages                                  
Hit http://archive.canonical.com vivid/partner amd64 Packages                       
Hit http://no.archive.ubuntu.com vivid-backports Release.gpg                        
Hit http://no.archive.ubuntu.com vivid Release                                      
Hit http://archive.canonical.com vivid/partner i386 Packages                        
Get:2 http://no.archive.ubuntu.com vivid-updates Release [63,5 kB]                  
Ign http://security.ubuntu.com vivid-security InRelease                             
Hit http://archive.canonical.com vivid/partner Translation-en                       
Hit http://no.archive.ubuntu.com vivid-backports Release                            
Hit http://no.archive.ubuntu.com vivid/main Sources                                 
Get:3 http://security.ubuntu.com vivid-security Release.gpg [933 B]                 
Hit http://no.archive.ubuntu.com vivid/restricted Sources                           
Hit http://no.archive.ubuntu.com vivid/universe Sources                             
Hit http://no.archive.ubuntu.com vivid/multiverse Sources                           
Ign http://dl.google.com stable/main Translation-en_US                              
Hit http://packages.osrfoundation.org vivid InRelease                               
Hit http://no.archive.ubuntu.com vivid/main amd64 Packages                          
Hit http://no.archive.ubuntu.com vivid/restricted amd64 Packages                    
Get:4 http://security.ubuntu.com vivid-security Release [63,5 kB]                   
Ign http://dl.google.com stable/main Translation-en                                 
Hit http://no.archive.ubuntu.com vivid/universe amd64 Packages                      
Hit http://no.archive.ubuntu.com vivid/multiverse amd64 Packages                    
Hit http://packages.ros.org vivid InRelease                                         
Hit http://no.archive.ubuntu.com vivid/main i386 Packages                           
Hit http://no.archive.ubuntu.com vivid/restricted i386 Packages                     
Hit http://packages.osrfoundation.org vivid/main amd64 Packages                     
Hit http://no.archive.ubuntu.com vivid/universe i386 Packages                       
Hit http://no.archive.ubuntu.com vivid/multiverse i386 Packages                     
Hit http://no.archive.ubuntu.com vivid/main Translation-en                          
Hit http://packages.ros.org vivid/main amd64 Packages                               
Hit http://no.archive.ubuntu.com vivid/multiverse Translation-en                    
Hit http://no.archive.ubuntu.com vivid/restricted Translation-en                    
Hit http://packages.osrfoundation.org vivid/main i386 Packages                      
Hit http://no.archive.ubuntu.com vivid/universe Translation-en                      
Get:5 http://no.archive.ubuntu.com vivid-updates/main Sources [82,8 kB]             
Get:6 http://no.archive.ubuntu.com vivid-updates/restricted Sources [1 366 B]       
Get:7 http://no.archive.ubuntu.com vivid-updates/universe Sources [37,7 kB]         
Hit http://packages.ros.org vivid/main i386 Packages                                
Get:8 http://no.archive.ubuntu.com vivid-updates/multiverse Sources [1 966 B]       
Get:9 http://security.ubuntu.com vivid-security/main Sources [41,3 kB]              
Get:10 http://no.archive.ubuntu.com vivid-updates/main amd64 Packages [195 kB]      
Get:11 http://no.archive.ubuntu.com vivid-updates/restricted amd64 Packages [3 283 B]
Get:12 http://no.archive.ubuntu.com vivid-updates/universe amd64 Packages [103 kB]  
Get:13 http://no.archive.ubuntu.com vivid-updates/multiverse amd64 Packages [3 496 B]
Get:14 http://no.archive.ubuntu.com vivid-updates/main i386 Packages [193 kB]       
Get:15 http://security.ubuntu.com vivid-security/restricted Sources [28 B]          
Get:16 http://no.archive.ubuntu.com vivid-updates/restricted i386 Packages [3 273 B]
Get:17 http://no.archive.ubuntu.com vivid-updates/universe i386 Packages [104 kB]   
Get:18 http://security.ubuntu.com vivid-security/universe Sources [16,0 kB]         
Get:19 http://no.archive.ubuntu.com vivid-updates/multiverse i386 Packages [3 680 B]
Hit http://no.archive.ubuntu.com vivid-updates/main Translation-en                  
Hit http://no.archive.ubuntu.com vivid-updates/multiverse Translation-en            
Get:20 http://security.ubuntu.com vivid-security/multiverse Sources [1 966 B]       
Hit http://no.archive.ubuntu.com vivid-updates/restricted Translation-en            
Hit http://no.archive.ubuntu.com vivid-updates/universe Translation-en              
Hit http://no.archive.ubuntu.com vivid-backports/main Sources                       
Hit http://no.archive.ubuntu.com vivid-backports/restricted Sources                 
Hit http://no.archive.ubuntu.com vivid-backports/universe Sources                   
Get:21 http://security.ubuntu.com vivid-security/main amd64 Packages [113 kB]       
Hit http://no.archive.ubuntu.com vivid-backports/multiverse Sources                 
Hit http://no.archive.ubuntu.com vivid-backports/main amd64 Packages                
Hit http://no.archive.ubuntu.com vivid-backports/restricted amd64 Packages          
Hit http://no.archive.ubuntu.com vivid-backports/universe amd64 Packages            
Hit http://no.archive.ubuntu.com vivid-backports/multiverse amd64 Packages          
Hit http://no.archive.ubuntu.com vivid-backports/main i386 Packages                 
Hit http://no.archive.ubuntu.com vivid-backports/restricted i386 Packages           
Hit http://no.archive.ubuntu.com vivid-backports/universe i386 Packages             
Hit http://no.archive.ubuntu.com vivid-backports/multiverse i386 Packages           
Hit http://no.archive.ubuntu.com vivid-backports/main Translation-en                
Hit http://no.archive.ubuntu.com vivid-backports/multiverse Translation-en          
Get:22 http://security.ubuntu.com vivid-security/restricted amd64 Packages [28 B]   
Hit http://no.archive.ubuntu.com vivid-backports/restricted Translation-en          
Hit http://no.archive.ubuntu.com vivid-backports/universe Translation-en            
Get:23 http://security.ubuntu.com vivid-security/universe amd64 Packages [53,0 kB]  
Get:24 http://security.ubuntu.com vivid-security/multiverse amd64 Packages [3 496 B]
Ign http://packages.osrfoundation.org vivid/main Translation-en_US                  
Get:25 http://security.ubuntu.com vivid-security/main i386 Packages [113 kB]        
Ign http://packages.osrfoundation.org vivid/main Translation-en                     
Get:26 http://security.ubuntu.com vivid-security/restricted i386 Packages [28 B]    
Ign http://packages.ros.org vivid/main Translation-en_US                            
Get:27 http://security.ubuntu.com vivid-security/universe i386 Packages [53,0 kB]
Get:28 http://security.ubuntu.com vivid-security/multiverse i386 Packages [3 680 B] 
Ign http://packages.ros.org vivid/main Translation-en                               
Hit http://security.ubuntu.com vivid-security/main Translation-en  
Hit http://security.ubuntu.com vivid-security/multiverse Translation-en
Hit http://security.ubuntu.com vivid-security/restricted Translation-en
Hit http://security.ubuntu.com vivid-security/universe Translation-en
Fetched 1 260 kB in 3s (323 kB/s)
Reading package lists... Done

Originally posted by ros_geller on ROS Answers with karma: 92 on 2015-09-11

Post score: 0


Original comments

Comment by gvdhoorn on 2015-09-11:
Please list all the steps that you took to get to the point where you try to run sudo apt-get install ros-... This sounds like something is not correctly setup.

Comment by RodBelaFarin on 2015-09-11:
Did you install the additional system dependencies for 14.04.2 like suggested in Tutorial step 1.4?

Comment by ros_geller on 2015-09-11:
I followed the steps in the tutorial to the point. I also tried the additional steps for 14.04.2, but this just gave a long list of additional packages it couldn't locate.

E: Unable to locate package xserver-xorg-dev-lts-utopic E: Unable to locate package mesa-common-dev-lts-utopic

  • 10 more

Comment by gvdhoorn on 2015-09-11:
Please update (edit) your question with the output of cat /etc/apt/sources.list.d/ros-latest.list and sudo apt-get update.

Comment by ros_geller on 2015-09-11:
Updated with printouts

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

$ cat /etc/apt/sources.list.d/ros-latest.list
deb http://packages.ros.org/ros/ubuntu vivid main

Ubuntu Vivid is version 15.04, not 14.04 (Trusty) and there are no builds of Indigo for that version of Ubuntu (from REP 3: Target Platforms - Platforms by Distribution):

Indigo Igloo (May 2014)

  • Ubuntu Saucy (13.10)
  • Ubuntu Trusty (14.04 LTS)

So the error you got from apt-get is completely correct: there is no ros-indigo-desktop-full package installable.

Can also add that i have installed ROS Jade without any problems at all, so there is nothing wrong with my Ubuntu distr (as far as i can tell).

That is also expected: ROS Jade is released for Ubuntu Vivid (see REP 3: Target Platforms - Jade Turtle (May 2015 - May 2017)).


Originally posted by gvdhoorn with karma: 86574 on 2015-09-11

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by ros_geller on 2015-09-11:
I, for some reason, thought I had trusty, but apparently I got vivid. That makes everything very obvious. I'm kinda new to Linux aswell, so I didn't immediately connect the dots when I saw the names and version number.

Thank you for sorting that out for me!

Comment by JohnnyQ on 2015-10-04:
OK.,. gvdhoorn, I read all the info you posted for this answer but I get the same issue installing Jade-Desktop-Full.. it stops me at "E: Unable to locate package ros-jade-desktop-full"... I have Trusty 14.04 installed. I have looked everywhere with no avail. Can you help me?

Comment by JohnnyQ on 2015-10-04:
Oh I forgot to tell you.. this is on a MAC install of Ubuntu, which is working fine.

Comment by gvdhoorn on 2015-10-05:
I think this is related to your other question, which was answered. Turned out you are trying to install ROS on an unsupported cpu architecture.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.