Rosanswers logo

I am running ROS jade on an Ubuntu 14.04 OS and I am trying to connect the Gazebo simulator to ROS. I have followed the tutorials to connect Gazebo to ROS on the Gazebo website, and now I am trying to download the URDF of the Pioneer 3dx robot (since that is the robot I am using), but I am running into a problem. I have placed the URDF file from a github site into the src directory of my catkin_ws, but whenever I run "catkin_make" I always get this error:

CMake Error at /opt/ros/jade/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a package configuration file provided by "controller_manager" with any of the following names:


Add the installation prefix of "controller_manager" to CMAKE_PREFIX_PATH or set "controller_manager_DIR" to a directory containing one of the above files. If "controller_manager" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): ua_ros_p3dx/p3dx_control/CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred! See also "/home/tatum/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/tatum/catkin_ws/build/CMakeFiles/CMakeError.log". Invoking "cmake" failed

I have looked online to find an answer to this problem but the answers posted do not help me. I think this has to do with the fact that the the other questions were based on the indigo distribution. Please help!!

Originally posted by thumper on ROS Answers with karma: 13 on 2015-08-12

Post score: 1


1 Answer 1


Rosanswers logo

You don't have the controller_manager package installed. As ros_control is not yet release for Jade, try to clone the ros_control repository with git clone https://github.com/ros-controls/ros_control.git -b jade_devel and try again.

If (when) it is release, you can install it using `sudo apt-get install ros-jade-controller-manager'.

Originally posted by mgruhler with karma: 12390 on 2015-08-13

This answer was ACCEPTED on the original site

Post score: 4

Original comments

Comment by thumper on 2015-08-13:
Thank you so much!!!! It worked!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.