0
$\begingroup$

We bought a new Create2 robot and started using it. But when we issue the dock command the robot moves for a bit and does not go back to the base.

The base is not hidden or obstructed and the create2 is just a couple of feet away. we need help to figure out why it does not see the base.

Just to clarify that even using the DOCK button on the create2 does not make the create2 go back to the base

$\endgroup$
  • $\begingroup$ If you press the dock button on the Roomba itself, does it dock properly? $\endgroup$ – Ben Mar 23 '15 at 16:49
  • $\begingroup$ that is correct the dock button does not send the robot to base $\endgroup$ – Jack Mar 23 '15 at 18:08
2
$\begingroup$

The dock command and pressing the dock button on the robot enable the same behavior. The robot does not go directly to the dock, because it does not know where the dock is. Instead, it drives around until it happens to encounter the dock's infrared beams, which extend about 10 feet in front of the dock. Once Roomba encounters the dock beams, it will line up with the charging base and dock.

If you place the robot in front of the dock, facing it, and press the dock button, it should go directly onto the dock. If the robot starts somewhere else, it may take several minutes to find the dock. This is normal.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.