0
$\begingroup$

Rosanswers logo

While running the rosrun hokuyo_node, I get the error getID failed: timeout reached (in hokuyo::laser::laserReadLine)

how to fix it. I followed the Hokuyo tutorials. And I have given it permission.


Originally posted by Truce on ROS Answers with karma: 33 on 2015-07-08

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Make sure the laser driver is installed correctly and the system can read it. Connect your laser and check if the system can detect it and if it is configured correctly.

$ ls -l /dev/ttyACM0 

When the laser is connected, the system can see it using the following command line:

crw-rw-rw- 1 root dialout 166, 0 Jun 15 11:17 /dev/ttyACM0

Once everything is OK, we are going to switch on the laser. Start roscore in one shell and in another shell execute the following command:

$ rosrun hokuyo_node hokuyo_node

If everything is fine, you will see the following output:

[ INFO] [1378076340.184643618]: Connected to device with ID: H10XX40X

Originally posted by redskydeng with karma: 118 on 2015-07-09

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Truce on 2015-07-10:
Yes I did whatever you said. It worked fine till : crw-rw-rw- 1 root dialout 166, 0 Jun 15 11:17 /dev/ttyACM0

then trying to get ID i was getting error. Somehow after taking a break and restarting everything. It worked. Thanks for your help.

Comment by 85pando on 2015-09-25:
On the youbot there should also be a /dev/sensors/hokuyo symlink that you can set by:

$ rosparam set hokuyo_node/port /dev/sensors/hokuyo
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.