0
$\begingroup$

Rosanswers logo

Hi guys I'm having problems to detect hokuyo UTM-30LX-EW Laser Scanner. I followed the guide installation on wikiros and first I installed the hokuyo_node (actually I tried also with other package, urg_node). The problem is in the second step: I insert the Ethernet cable and when I search the laser into dev/ I don't find it. I found dev/tty0, dev/ttyS0 etc.. but not dev/ttyACM0 as is described in the guide. How I can detect the laser?


Originally posted by enri on ROS Answers with karma: 13 on 2015-06-30

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

With the Hokuyo UTM-30LX-EW connected through ethernet, you can use the urg_node, setting the ip_address parameter value. Default factory Hokuyos come with IP 192.168.0.10.

rosrun urg_node urg_node _ip_address:=192.168.0.10

-- Edit 1:

PC and laser must be on the same net 192.168.0.XX. Then, you should be able to ping the laser first,

ping 192.168.0.10

-- Edit 2:

If it does not work on a PC with IP 192.168.0.XX, maybe your Hokuyo laser has a different IP address.

To be sure, you can reset the laser IP address to the default one (192.168.0.10), following the instructions from the Laser specification (last page, section 9 - Ethernet settings - IP Initialization ), provided at the Hokuyo webpage.

If you manage to make it work with the default IP address but then you need to work in a different sub net, in the Hokuyo webpage there is a tool (for Windows) to change the laser IP address.


Originally posted by fherrero with karma: 738 on 2015-06-30

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by enri on 2015-06-30:
[ERROR] [1435675488.414973920]: Error connecting to Hokuyo: Could not open network Hokuyo: 192.168.0.10:10940 could not open ethernet port.

this is what the command returns

Comment by fherrero on 2015-06-30:
Reading this question, they basically say your computer and the laser must be on the same net (192.168.0.XX).

Comment by enri on 2015-07-01:
Unfortunately I cannot fix that problem, I have already read all the post that I found. This afternoon I try with this other guide: [http://dasl.mem.drexel.edu/wiki/index.php/3._Using_a_hokuyo_LIDAR_with_ROS] In this guide I don't change the IP!

thanks fherrero for the help!

Comment by fherrero on 2015-07-01:
That guide looks a bit old (ubuntu 10 and ROS Fuerte). I recommend you to reset the laser IP address (see Edit 2 of my answer) and continue trying with urg_node

Comment by enri on 2015-07-03:
Thanks fherrero for the advices, Finally it works!! I had to initialize it manually!

Comment by zlg9 on 2021-05-18:
My Hokuyo UST-10LX does not reset when connecting COM- to IP-RESTART for +2 second. Actually I cut those two wires (light blue and gray) and made a solid contact for several time, each more than 2 second. LED remains solid blue and does not blink. I don't have the existing IP address to work with the LiDAR. Any Idea ?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.