Rosanswers logo

I use ubuntu 12.04 and fuerte. I install lsd_slam and its readme says that

Using `live_slam`
If you want to directly use a camera.
rosrun lsd_slam_core live_slam /image:=<yourstreamtopic> /camera_info:=<yourcamera_infotopic>
When using ROS camera_info, only the image dimensions and the `K` matrix from the camera info messages will be used - hence the video has to be rectified.

I want to use live_slam on ROS. To install camera driver, I find this blog.

Firstly, I run 1.b section not 1.a. Then I tried rosdep install gscam, I get below error message.

ERROR: Rosdep cannot find all required resources to answer your query Missing resource gscam ROS path [0]=/opt/ros/fuerte/share/ros ROS path [1]=/opt/ros/fuerte/share ROS path [2]=/opt/ros/fuerte/stacks ROS path [3]=/home/user/fuerte_workspace/sandbox/

Conetnt of bashrc file is below :

source /opt/ros/fuerte/setup.bash export ROS_WORKSPACE=~/fuerte_workspace/ export ROS_PACKAGE_PATH+=:~/fuerte_workspace/sandbox/ export ROS_PACKAGE_PATH+=:~/fuerte_workspace/gscam/

How can I handle this error? Or, how can I get frame from webcam using ubuntu, ROS, fuerte?

Originally posted by jossy on ROS Answers with karma: 83 on 2015-06-29

Post score: 0


1 Answer 1


Rosanswers logo

Did you install gscam?

rosdep does NOT install gscam, but dependencies for gscam.

Originally posted by dornhege with karma: 31395 on 2015-06-29

This answer was ACCEPTED on the original site

Post score: 0

Original comments

Comment by jossy on 2015-06-29:
I install gscam using svn. It locates under fuerte_workspace.

Comment by dornhege on 2015-06-29:
Something with your paths seems to be wrong. You list the gscam export, but the error provided by rosdep does not contain that path. Maybe you forgot to source something.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.