0
$\begingroup$

Rosanswers logo

I'm trying to install ROS Hydro on my Raspberry Pi2 using the latest version of Raspbian.
These are the instructions that I'm following: http://wiki.ros.org/ROSberryPi/Setting%20up%20Hydro%20on%20RaspberryPi

When I get down to sudo apt-get install python-rosdep python-rosinstall-generator build-essential I start getting a bunch of errors and I can't figure out what to do. I'm fairly new to Linux so most of this goes right over my head.

Here's what happens when I run that line of code:

Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
Some packages could not be installed. This may mean that you have
request an impossible situation or if you are using the unstable distribution that some requrieed packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-rosdep :
                      Depends : python:any (>= 2.7.1-0ubuntu2) but it is not installable
                      Depends: python-catkin-pkg but it is not going to be installed
                      Depends: python-rospkg (>= 1.0.34) but it is not going to be installed
                      Depends: python-rosdistro (>= 0.4.0) but it is not going to be installed
 python-rosinstall-generator :
                      Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable
                      Depends: python-catkin-pkg (>= 0.1.28) but it is not going to be installed
                      Depends: python-rosdistro (>= 0.3.4) but it is not going to be installed
                      Depends: python-rospkg but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any help is appreciated, thanks!!


Originally posted by rangen4life4 on ROS Answers with karma: 1 on 2015-06-25

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The documentation you are following is for the original Raspberry Pi. For the Raspberry Pi 2 you should follow these instructions: http://wiki.ros.org/jade/Installation/UbuntuARM

Or these for the LTS release indigo: http://wiki.ros.org/indigo/Installation/UbuntuARM


Originally posted by tfoote with karma: 58457 on 2015-06-27

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by rangen4life4 on 2015-06-30:
Is there anyway that I can install ROS hydro on a Raspberry PI 2? Those instructions are for ROS jade.

Comment by tfoote on 2015-06-30:
You can compile from source. The Raspberry Pi 2 is much newer than Hydro and Hydro is EOL now. That's not a supported configuration.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.