0
$\begingroup$

Rosanswers logo

Hi, recently I upgraded my ODROID XU3 using apt-get and since then I haven't been able to launch robot state publisher which is crucial for my finals project. Whenever I want to launch my launch file, it always died with error code -7 and when I use rosrun for robot state publisher it returned 'Bus error' to the terminal.

  1. Is there a quick solution to this?
  2. If not, is there an alternative to robot state publisher? I intend to use my robot for gmapping, and I haven't been able to run robot state publisher in a separate machine like my laptop and connect to the ODROID that contains the gmapping, freenect, and differential drive package. It ended up with no mapping data received and the robot model has plenty of errors.
  3. Is there an old ROS repository that I can download and replace the one in my ODROID?

Really need help real quick, it was stupid of me to update when I had the whole thing worked out, now I'm screwed.


Originally posted by Cubex on ROS Answers with karma: 11 on 2015-06-01

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

See this question: http://answers.ros.org/question/209686/turtlebot-apt-get-update-has-generated-an-error-on-minimallaunch/

The most straightforward solution that is proposed is checking out and building the robot_model stack from source.


Originally posted by ahendrix with karma: 47576 on 2015-06-01

This answer was ACCEPTED on the original site

Post score: 5


Original comments

Comment by mikepurvis on 2015-07-22:
This worked for me on an aarch64 board— I built both robot_model and robot_state_publisher from source and it cooperated.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.