Rosanswers logo

Hi all.

I am trying to compile the rtt_ros_integration stack, for which I installed Orocos from the AUR (I'm using Archlinux). However, it seems like the installed Orocos looks for a manifest.xml file which it can't find when compiling the stack. The error looks like this:

Orocos-RTT found in /usr/lib64/cmake/orocos-rtt/orocos-rtt-gnulinux-libraries.cmake
-- Found orocos-rtt 2.6.0 for the gnulinux target. Available transports: mqueue

This package is in your ROS_PACKAGE_PATH, so I'm using rosbuild-style package building.
[UseOrocos] Building package src
[rosbuild] Building package src
[rosbuild] Error from syntax check of src/manifest.xml
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/opt/ros/indigo/lib/python2.7/site-packages/roslib/manifest.py", line 139, in parse_file
    return roslib.manifestlib.parse_file(Manifest(), file)
  File "/opt/ros/indigo/lib/python2.7/site-packages/roslib/manifestlib.py", line 497, in parse_file
    raise ValueError("Invalid/non-existent manifest file: %s"%file)
ValueError: Invalid/non-existent manifest file: manifest.xml
CMake Error at /opt/ros/indigo/share/ros/core/rosbuild/private.cmake:78 (message):
  [rosbuild] Syntax check of src/manifest.xml failed; aborting
Call Stack (most recent call first):
  /opt/ros/indigo/share/ros/core/rosbuild/public.cmake:174 (_rosbuild_check_manifest)
  /usr/lib64/cmake/orocos-rtt/UseOROCOS-RTT.cmake:115 (rosbuild_init)
  rtt_ros_integration/rtt_ros/CMakeLists.txt:7 (include)

-- Configuring incomplete, errors occurred!
See also "/home/wko/catkin_ws/build/CMakeFiles/CMakeOutput.log".
Makefile:1243: recipe for target 'cmake_check_build_system' failed
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed
✗ - status code 1

Anyone an idea on how to fix this? Please let me know if you encountered the same and how you solved it.

P.S. I also tried compiling Orocos from source, with no success due to some Ruby/Gem issues.

Originally posted by HououinKyouma on ROS Answers with karma: 5 on 2015-05-25

Post score: 0

Original comments

Comment by gvdhoorn on 2015-05-25:
Please add which version of ROS you are targeting. I think 2.6.0 is a bit old for orocos. I'd try at the very least 2.7+.

Comment by HououinKyouma on 2015-05-25:
I see, I already suspected it might be an old version since it was still using the rosbuild tools rather than catkin. I'm trying to make it work for ros indigo, so guess I'll try to compile the latest version from source again. Thanks for the tip!


1 Answer 1


Rosanswers logo

As pointed out in the comments, this error occurs because of incompatible versions. I solved this problem by following the instructions here:


This installs version 2.7, which is good enough for compiling rtt_ros_integration. However, in order to compile the orocos_toolchain I had to switch to the master branch for only the utilrb and typelib repositories. Also, instead of creating a separate workspace for orocos I just put everything in my existing catkin workspace. Using two different workspaces caused some problems with finding packages. Now everything compiles if I issue catkin_make_isolated.

Originally posted by HououinKyouma with karma: 5 on 2015-05-28

This answer was ACCEPTED on the original site

Post score: 0


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.