0
$\begingroup$

Rosanswers logo

Hi all

I'm using the navigation stack in my robot and every time i send a goal using rviz (2D Nav Goal) it throws me the following:

[ WARN] [1431013577.749213787]: The goal sent to the navfn planner is off the global costmap. Planning will always fail to this goal.

[ WARN] [1431013578.746803719]: The goal sent to the navfn planner is off the global costmap. Planning will always fail to this goal.

[ WARN] [1431013579.747597482]: The goal sent to the navfn planner is off the global costmap. Planning will always fail to this goal.

[ WARN] [1431013580.747194408]: The goal sent to the navfn planner is off the global costmap. Planning will always fail to this goal.

[ WARN] [1431013581.747623215]: The goal sent to the navfn planner is off the global costmap. Planning will always fail to this goal.

[ WARN] [1431013582.747012998]: The goal sent to the navfn planner is off the global costmap. Planning will always fail to this goal.

[ERROR] [1431013583.745273259]: Aborting because a valid plan could not be found. Even after executing all recovery behaviors

my global costmap is the following:

global_costmap:
  global_frame: /rosphere/odom_combined  
  robot_base_frame: /rosphere/base_footprint
  transform_tolerance: 5.0
  update_frequency: 0.5
  publish_frequency: 0.0
  static_map: false
  rolling_window: true
  width: 100.0
  height: 100.0
  resolution: 0.2

and the same for the local costmap, only changing the width, height and resolution (20,20, 0.05 respectively)

The goal I'm sending is just one meter from the base on x-axis so the action should be just to move straight forward. On Rviz the grid is set to 20 plane cell count and 1meter per cell.

I've changed the resolution, width and height of both costmaps and it's always the same. Any ideas? if you need more info just ask.

Salvador


Originally posted by salvadorvalisena on ROS Answers with karma: 1 on 2015-05-07

Post score: 0


Original comments

Comment by salvadorvalisena on 2015-05-08:
I'm new at this so i don't know if a did it. i set all the parameters for the .yaml with http://wiki.ros.org/move_base#Parameters http://wiki.ros.org/costmap_2d#costmap_2d.2BAC8-layered.Parameters http://wiki.ros.org/base_local_planner#Parameters

Comment by salvadorvalisena on 2015-05-08:
@Humpelstilzchen thank you for taking time to look at my question. It's resolved, I was publishing into the odom_combined frame and it has to be into the base_footprint frame.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Have you located your bot on the map prior to sending the goal?


Originally posted by Humpelstilzchen with karma: 1504 on 2015-05-08

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.