0
$\begingroup$

Rosanswers logo

Hi,

Maybe my question is a bit dump because I am very new to hector slam and even to ROS. I have installed ROS and hector slam (indigo). When I was trying to do the tutorial, after I typed roslaunch hector_slam_launch tutorial.launch and press enter, Rviz started fine with no error. I can rotate the grid and saw Global Status is in red text (no data feeding into Rviz).

Then I typed rosbag play Team_Hector_MappingBox_RoboCup_2011_Rescue_Arena.bag --clock in another console and there is no error shown. I could see the [RUNNING] line being showed and I guess the data is being fed to Rviz?

However, there is nothing shown in Rviz, I can still rotate the grid but there is no map being created. Also, I saw the Global Status became green and there was a check sign. I could also see the "ROS Elapsed" at the bottom is running.

When I added a TF, I could see two coordinates moving but there is just no map.

I saved the file to an alternative path (when I clicked save it said the file cannot be open, so I have to save a copy to another path). The content of the file is shown below:

Panels:
  - Class: rviz/Displays
    Help Height: 78
    Name: Displays
    Property Tree Widget:
      Expanded:
        - /Global Options1
        - /Status1
      Splitter Ratio: 0.5
    Tree Height: 565
  - Class: rviz/Selection
    Name: Selection
  - Class: rviz/Tool Properties
    Expanded:
      - /2D Pose Estimate1
      - /2D Nav Goal1
      - /Publish Point1
    Name: Tool Properties
    Splitter Ratio: 0.588679
  - Class: rviz/Views
    Expanded:
      - /Current View1
    Name: Views
    Splitter Ratio: 0.5
  - Class: rviz/Time
    Experimental: false
    Name: Time
    SyncMode: 0
    SyncSource: ""
Visualization Manager:
  Class: ""
  Displays:
    - Alpha: 0.5
      Cell Size: 1
      Class: rviz/Grid
      Color: 160; 160; 164
      Enabled: true
      Line Style:
        Line Width: 0.03
        Value: Lines
      Name: Grid
      Normal Cell Count: 0
      Offset:
        X: 0
        Y: 0
        Z: 0
      Plane: XY
      Plane Cell Count: 10
      Reference Frame: <Fixed Frame>
      Value: true
    - Angle Tolerance: 0.1
      Class: rviz/Odometry
      Color: 255; 25; 0
      Enabled: true
      Keep: 100
      Length: 1
      Name: Odometry
      Position Tolerance: 0.1
      Topic: ""
      Value: true
    - Class: rviz/TF
      Enabled: false
      Frame Timeout: 15
      Frames:
        All Enabled: true
      Marker Scale: 1
      Name: TF
      Show Arrows: true
      Show Axes: true
      Show Names: true
      Tree:
        {}
      Update Interval: 0
      Value: false
  Enabled: true
  Global Options:
    Background Color: 48; 48; 48
    Fixed Frame: map
    Frame Rate: 30
  Name: root
  Tools:
    - Class: rviz/Interact
      Hide Inactive Objects: true
    - Class: rviz/MoveCamera
    - Class: rviz/Select
    - Class: rviz/FocusCamera
    - Class: rviz/Measure
    - Class: rviz/SetInitialPose
      Topic: /initialpose
    - Class: rviz/SetGoal
      Topic: /move_base_simple/goal
    - Class: rviz/PublishPoint
      Single click: true
      Topic: /clicked_point
  Value: true
  Views:
    Current:
      Class: rviz/Orbit
      Distance: 16.2326
      Enable Stereo Rendering:
        Stereo Eye Separation: 0.06
        Stereo Focal Distance: 1
        Swap Stereo Eyes: false
        Value: false
      Focal Point:
        X: 0
        Y: 0
        Z: 0
      Name: Current View
      Near Clip Distance: 0.01
      Pitch: 0.350399
      Target Frame: <Fixed Frame>
      Value: Orbit (rviz)
      Yaw: 0.425397
    Saved: ~
Window Geometry:
  Displays:
    collapsed: false
  Height: 846
  Hide Left Dock: false
  Hide Right Dock: false
  QMainWindow State: 000000ff00000000fd00000004000000000000013c000002c4fc0200000008fb0000001200530065006c0065006300740069006f006e00000001e10000009b0000006400fffffffb0000001e0054006f006f006c002000500072006f007000650072007400690065007302000001ed000001df00000185000000a3fb000000120056006900650077007300200054006f006f02000001df000002110000018500000122fb000000200054006f006f006c002000500072006f0070006500720074006900650073003203000002880000011d000002210000017afb000000100044006900730070006c0061007900730100000028000002c4000000dd00fffffffb0000002000730065006c0065006300740069006f006e00200062007500660066006500720200000138000000aa0000023a00000294fb00000014005700690064006500530074006500720065006f02000000e6000000d2000003ee0000030bfb0000000c004b0069006e0065006300740200000186000001060000030c00000261000000010000010f000002c4fc0200000003fb0000001e0054006f006f006c002000500072006f00700065007200740069006500730100000041000000780000000000000000fb0000000a005600690065007700730100000028000002c4000000b000fffffffb0000001200530065006c0065006300740069006f006e010000025a000000b200000000000000000000000200000490000000a9fc0100000001fb0000000a00560069006500770073030000004e00000080000002e10000019700000003000004b00000003efc0100000002fb0000000800540069006d00650100000000000004b0000002f600fffffffb0000000800540069006d0065010000000000000450000000000000000000000259000002c400000004000000040000000800000008fc0000000100000002000000010000000a0054006f006f006c00730100000000ffffffff0000000000000000
  Selection:
    collapsed: false
  Time:
    collapsed: false
  Tool Properties:
    collapsed: false
  Views:
    collapsed: false
  Width: 1200
  X: 54
  Y: 14

Can anyone help me on this please? Thanks


Originally posted by StevenJiang on ROS Answers with karma: 3 on 2015-04-25

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Have you checked all the Displays are correctly setup or subscribed to the proper topic??

Global Options -- map (according to your file, you already have this one)

Map -- /map (add using Topic and add /map)

Those should be the more important ones for map I think.

Best


Originally posted by Victor Gomez with karma: 50 on 2015-04-27

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by StevenJiang on 2015-04-27:
Hi, thanks for replying.

The default setting in Global Options is 'map' which I assume is the correct one? However there is nothing shown on the grid.

Sorry I don't understand what 'Map -- /map (add using Topic and add /map)' mean (I am a newbie in ROS). Could you elaborate a bit more?

Thanks.

Comment by Victor Gomez on 2015-04-28:
In the rviz window, in the left part you see Displays. Below of that you find the Global options, which you already have correctly. Below of that, you find an Add button, click it. In the new window, choose by topic and choose map. Hope it works. Let us know.

Comment by StevenJiang on 2015-04-28:
Ok it worked! Thanks a lot! But when I added a map by types, there is no map showing. What is the difference between topics and types?

Comment by Victor Gomez on 2015-04-29:
When you add by topic, it automatically selects the information to be displayed. When you add by types, in the Display menu, you have to choose among the different topic that publishes to map (which in your case should only be 1). If it works now, mark the question as answered please.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.