0
$\begingroup$

Rosanswers logo

Can any one solve this issue?

Base path: /home/zarneel/rgbdslam_catkin_ws

Source space: /home/zarneel/rgbdslam_catkin_ws/src

Build space: /home/zarneel/rgbdslam_catkin_ws/build

Devel space: /home/zarneel/rgbdslam_catkin_ws/devel

Install space: /home/zarneel/rgbdslam_catkin_ws/install

Running command: "make cmake_check_build_system" in "/home/zarneel/rgbdslam_catkin_ws/build"

Running command: "make -j4 -l4" in "/home/zarneel/rgbdslam_catkin_ws/build"

[ 0%] [ 0%] [ 0%] [ 0%] Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_f

Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_b

Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_s

Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui

[ 13%] Built target siftgpu_proj

[ 26%] [ 26%] Built target rgbdslam_generate_messages_lisp

Built target rgbdslam_generate_messages_cpp

[ 35%] Built target rgbdslam_generate_messages_py

[ 35%] [ 35%] Built target rgbdslam_gencpp

Built target rgbdslam_generate_messages

make[2]: *** No rule to make target /usr/lib/libcxsparse.so.2.2.3', needed by /home/zarneel/rgbdslam_catkin_ws/devel /lib/rgbdslam/rgbdslam'. Stop.

make[1]: *** [rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/all] Error 2

make: *** [all] Error 2

Invoking "make -j4 -l4" failed


Originally posted by Zari on ROS Answers with karma: 35 on 2015-04-18

Post score: 2


Original comments

Comment by Wolf on 2015-04-19:
Which command do you execute?? Which package? ROS version? OS version? Please post more information, otherwise there won't be anyone who can help you....

Comment by Zari on 2015-04-19:
I got this error when I run command "catkin_make" I am trying to run rgbdslam_v2 on ROS Indigo.Ubuntu version 14.04

Complete execution with error is mentioned above.

Comment by Zari on 2015-04-19:
I followed the same steps mentioned here http://felixendres.github.io/rgbdslam_v2/

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I've changed the line in the src/rgbdslam_v2/CMakeLists.txt to the following:

SET(LIBS_LINK GL GLU cholmod /usr/lib/x86_64-linux-gnu/libcxsparse.so.3.1.2 #/usr/lib/libcxsparse.so.2.2.3
${G2O_LIBRARIES} ${QT_LIBRARIES} ${QT_QTOPENGL_LIBRARY} ${GLUT_LIBRARY} ${OPENGL_LIBRARY} ${OpenCV_LIBS})

And the package compiled. I guess author haven't made a proper cmake search module for it just yet.


Originally posted by DikobrAz with karma: 36 on 2015-05-18

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by Zari on 2015-05-19:
Thanks for reply.I just replaced the newer version with older one and it works fine for me.

Comment by Mr. Kro on 2016-05-10:
Worked for me, thanks a lot! Just one thing, you forgot one closing bracket and that might generate weird error messages

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.