0
$\begingroup$

Rosanswers logo

Hello,

I am working on Ubuntu 14.04 with ROS Indigo

I was following the turtlebot tutorials, and found that the

roslaunch turtlebot_bringup 3dsensor.launch

instruction in the 3d visualisation tutorial didn't recognize the kinect, while

roslaunch freenect_launch freenect.launch

did. Then i went on the SLAM tutorial but had the same problem because it use the 3dsensor.launch file. I had to remove the

agr name="3d_sensor" default="$( env TURTLEBOT_3D_SENSOR)"

line of the 3dsensor.launch and manually select the kinect.launch file in the

include file="$(find turtlebot_bringup)/launch/includes/3dsensor/$(arg 3dsensor ).launch.xml

Is that a problem that happened to others, and actually need a modification of the file to work, or is it that i did something wrong ?

EDIT : After following jihoonl's advice, i deleted ROS and re installed it from scratch, and this time this part worked fine. But i had another problem when loading the map i created during "SLAM Map Building with TurtleBot"'s tutorial : The amdl_demo.launch was loading a map whose path was fixed ( find turtlebot_navigation`/maps/willow-2010-02-18-0.10.yaml )and not dependent on the ROS environment variable we were asked to choose. Did i once again forgot some part of the tutorials ?


Originally posted by Swan Baigne on ROS Answers with karma: 47 on 2015-03-26

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This link will help you.

http://wiki.ros.org/turtlebot/Tutorials/indigo/Kinect%20Setup


Originally posted by jihoonl with karma: 634 on 2015-03-29

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Swan Baigne on 2015-03-30:
Thanks for your answers, i already did this but it seems it didn't register in my source.bash

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.