0
$\begingroup$

Rosanswers logo

Hi,

I've been trying to install MoveIt! on ROS Indigo in Ubuntu 14.04 and have been running into issues.

I first tried to install it using the binary installation instructions: sudo apt-get install ros-indigo-moveit-ros However, it says:

*Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 ros-indigo-moveit-full : Depends: ros-indigo-moveit-commander but it is not going to be installed
                          Depends: ros-indigo-moveit-ros but it is not going to be installed
                          Depends: ros-indigo-moveit-setup-assistant but it is not going to be installed*

I have also tried installing it from source. It seemed to work after a few times but when I try to run a tutorial program, it says "ImportError: No module named moveit_commander"

I tried reinstalling ROS multiple times to no avail.

I've been looking around online but it seems like other people are having similar issues. Has any been able to successfully install MoveIt?

Thanks


Originally posted by vkee on ROS Answers with karma: 127 on 2015-02-21

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

python-pyassimp became available for Trusty sometime ago so for Indigo this issue should be resolved (ie. you don't need to bother yourself building moveit_commander from source).

Note for ROS Kinetic users; there's an open issue again regarding pyassimp.


Originally posted by 130s with karma: 10937 on 2017-01-17

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

I ran into the same problem installing ros-indigo-moveit-python and ros-indigo-moveit-commander from debians on 14.04.

The problem is that the version of libassimp3 that these packages depend on (via their dependency on python-pyassimp) is not provided by the package manager on Trusty.

To fix this manually, download libassimp3_3.0~dfsg-3_amd64.deb from here: https://launchpad.net/ubuntu/+source/assimp

then install it using sudo dpkg -i. You should then be able to install ros-indigo-moveit-full and/or the packages included in the metapackage that depend on libassimp3.


Originally posted by jackie with karma: 296 on 2015-07-05

This answer was NOT ACCEPTED on the original site

Post score: 4

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.