0
$\begingroup$

Rosanswers logo

Dear community,

I'm having trouble with URDFs that used to work since Hydro. If they contain a collada (.dae) mesh which has with non meter units (e.g. centimeter):

--- collada_unit_meter.dae      2015-02-16 11:14:28.128423513 +0100
+++ collada_unit_centimeter.dae 2015-02-16 11:16:06.542388857 +0100
@@ -7,7 +7,7 @@
     </contributor>
     <created>2015-02-16T11:14:28</created>
     <modified>2015-02-16T11:14:28</modified>
-    <unit name="meter" meter="1"/>
+    <unit name="centimeter" meter="0.01"/>
     <up_axis>Z_UP</up_axis>
   </asset>
   <library_images/>
@@ -97,4 +97,4 @@
   <scene>
     <instance_visual_scene url="#Scene"/>
   </scene>
-</COLLADA>
\ No newline at end of file
+</COLLADA>

no mesh at all is displayed in rviz RobotModel. It seems the mesh is also ignored for MoveIt! collision checking.

Test files can be created by simply exporting the default cube as .dae in Blender. Once without modification and once with modified . These files can also be found here: https://gist.github.com/andreasBihlmaier/576b5bc3837c568a6730

Can anybody confirm this issue?

Regards, ahb

Addition: The same meshes (with unit != meter) worked fine and continue to work fine with gazebo. Actually, I convert the .sdf to .urdf using pysdf.


Originally posted by andreasBihlmaier on ROS Answers with karma: 56 on 2015-02-16

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Sounds like a regression to me, you should probably file a bug ticket for rviz. The fact that things ceased working also for moveit suggests a broader issue with how mesh loading works, however. Hopefully, a issue on rviz will trigger the necessary discussion of this.

While I can't confirm your issue directly, I also noticed changes in COLLADA handling between hydro and indigo. I encountered another issue where rendering didn't work in hydro, but did so in indigo (see drcsim Bitbucket #466).


Originally posted by Stefan Kohlbrecher with karma: 24361 on 2015-02-16

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by andreasBihlmaier on 2015-02-16:
I was not sure where to file the bug (rviz, urdfdom, ...), thus I wanted to ask here before.

Comment by demmeln on 2015-02-23:
I can confirm this issue. Meshes get loaded fine without any error message, but nothing is displayed. Re-exporting such that the unit is meter seems to be the only remedy. These are meshes that worked fine in rviz hydro.

Comment by demmeln on 2015-02-23:
These test meshes do not work for me with current ros indigo from apt on ubuntu 14.04: https://github.com/garaemon/rviz_collada_marker

Comment by andreasBihlmaier on 2015-02-24:
Against which repository should we fill a bug report?

Comment by demmeln on 2015-02-24:
I guess https://github.com/ros-visualization/rviz/issues

Comment by William on 2015-02-25:
Yes, please open an issue on rviz, and include what version you are using and the example repository you have linked in the original question.

Comment by andreasBihlmaier on 2015-02-25:
Done: https://github.com/ros-visualization/rviz/issues/853

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.