Rosanswers logo

Hello everyone, I am trying to follow the tutorials in wiki to install the ROS and learn something about it. I had successfully installed the ROS following the instructions here http://wiki.ros.org/ROSberryPi/Installing%20ROS%20Indigo%20on%20Raspberry%20Pi . Then I tried to learn some basic knowledge about it in tutorials. But when I came to this part http://wiki.ros.org/ROS/Tutorials/UnderstandingNodes , and I type sudo apt-get install ros-indigo-ros-tutorials and it returns Unable to locate package ros-indigo-ros-tutorials. Well then I kept going because I can see the turtle in the monitor. But when I came to the next part, and i requires me to install ros-indigo-rqt, and it still returns unable to locate package.

So I think maybe someone can help me out?

Originally posted by blackey on ROS Answers with karma: 21 on 2015-01-21

Post score: 2


1 Answer 1


Rosanswers logo

I had the same problem. Found a solution in the end of tutorial you linked. You have to change the name of the packages

$ cd ~/ros_catkin_ws

$ rosinstall_generator ros_tutorials --rosdistro indigo --deps --wet-only --exclude roslisp --tar > indigo-custom_ros.rosinstall

Next, update the workspace with wstool:

$ wstool merge -t src indigo-custom_ros.rosinstall
$ wstool update -t src

it downloaded the package for me but you have to add ros_catkin_ws to workspace path

now I have a new problem when i am trying to run rosrun turtlesim turtlesim_node I am getting this message

[rosrun] Couldn't find executable named turtlesim_node below /home/pi/ros_catkin_ws/src/ros_tutorials/turtlesim

Originally posted by Chickenman with karma: 110 on 2015-07-08

This answer was ACCEPTED on the original site

Post score: 0

Original comments

Comment by Chickenman on 2015-07-08:
Ok i am updating my status my turtlesim is working properly now without any problems if you have any questions feel free to ask maybe i would be able to help btw sorry for my bad english :)

Comment by Grzybek on 2015-10-23:
Can u tell me how u did this ?

Comment by Chickenman on 2015-10-23:
Can you install tutorial packages or which error message do you get. I gave you commands for installing tutorial packages. It worked for me.

Comment by Grzybek on 2015-10-23:
I had a problem with install but I did this with your commands. Now i have problem with turltesim_nodes

Comment by Chickenman on 2015-10-24:
Did you ran catkin_make ?

Try this command and send me what you got from console you probably did not setup your workspace correctly.

$ printenv | grep ROS

And tell me where is your ros_catkin_ws My is at /home/pi/ros_catkin_ws

Comment by Grzybek on 2015-10-24:
`ROS_ROOT=/opt/ros/indigo/share/ros ROS_PACKAGE_PATH=/home/pi/catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks ROS_MASTER_URI=http://localhost:11311 ROS_DISTRO=indigo ROS_ETC_DIR=/opt/ros/indigo/etc/ros My ros_catkin_ws is the same place where yours.

Comment by Grzybek on 2015-10-24:
And when i try use catkin_make in ros_catkin_ws i have pi@~/ros_catkin_ws $ catkin_make Base path: /home/pi/ros_catkin_ws Source space: /home/pi/ros_catkin_ws/src The specified base path "/home/pi/ros_catkin_ws" contains a CMakeLists.txt but "catkin_make" must be invoked in the the root of workspace

Comment by Chickenman on 2015-10-24:
ok so open your .bashrc file

$ cd
$ nano .bashrc

and put this two lines of text at the end of the file

source /opt/ros/indigo/setup.bash

source ~/ros_catkin_ws/devel/setup.bash

and save the file restart your console and try catkin_make or running the turtlesim

Comment by Grzybek on 2015-10-24:
Nothing has change. I have the same messages.

Comment by Chickenman on 2015-10-24:
ROS_PACKAGE_PATH=/home/pi/catkin_ws/src how you got this path there should be ROS_PACKAGE_PATH=/home/pi/ros_catkin_ws/src do you have catkin_ws or ros_catkin ws as your working directory ?

Comment by Grzybek on 2015-10-27:
I dont know. I installed ros by tutorial: http://wiki.ros.org/ROSberryPi/Installing%20ROS%20Indigo%20on%20Raspberry%20Pi and created ros_catkin_ws after that i go to "core ros tutorial" and create new ros workspace: catkin_ws.

Comment by Grzybek on 2015-10-27:
Next step was to install tutorial_package so i install it with your command. But ros cant find it by "roscd ros_tutorials" so i logout and log in as root. I copied dir with tutorials to /opt/ros/indigo/share/ And now ros can find this package. I use roscore , ros make turtlesim

Comment by Chickenman on 2015-10-28:
ok so you can use turtlesim now yeah ?. I am not verry skilled at ROS. On my Pc i am using catkin_ws but on raspberry i am using ros_catkin_ws as worskpace and i did not created another catkin_ws (which creation was described in "core ros tutorial") because it did not work for me well.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.