0
$\begingroup$

Rosanswers logo

hi, all. I am trying to run leg_detector with indigo-devel branch which is a part of people in ROS wiki.
I found that "odom_combined" was set to be " fixed_frame" from source code. Following error is output. And no message is output both in topic /leg_tracker_measurements and /visualization_marker.

[ WARN] [1378817011.705600206]: MessageFilter [target=/odom_combined ]: Dropped 100.00% of messages so far. Please turn the [ros.leg_detector.message_notifier] rosconsole logger to DEBUG for more information.

I am using a Turtlebot2( i.e. kobuki) mounted with a hokuyo URG04LX.

Firstly, to solve this problem, I think the topic "odom_combined" is output by node "robot_pose_ekf". So I added "robot_pose_ekf" in launch file, but the problem still existed. Add since I am using Turtlebot2, the node "robot_pose_ekf" is confict with another node "mobile_base_nodelet_manager" which also manges the transform between "base_footprint" and "odom" in tf tree.

I also have changed "odom_combined" to be "laser_link" in all cpp and cfg files. And I deleted both devel and build directories and rebuild this workspace by running "catkin_make". The above error still existed.

Pleaase give me helpful advices. Thank you! @David lu


Originally posted by scopus on ROS Answers with karma: 279 on 2014-12-29

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The leg detector translates all the laser readings into whatever the fixed_frame parameter is using a MessageFilter. If it can't translate them to that frame, it will give the error listed above.

For a turtlebot, you may want to set fixed_frame to just odom.


Originally posted by David Lu with karma: 10932 on 2014-12-29

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by scopus on 2014-12-29:
Thank you. It is ok if fixed_frame is set to be "odom". However, I stil wonder that why "laser_link" is not ok,since this is associated to laser itself which is used for detecting legs. By running "rosrun tf tf_echo /odom /laser_link", there exists transfrom between /odom and /laser_link. Thanks!

Comment by David Lu on 2014-12-29:
Because of how dynamic reconfigure works, you may have also needed to change the .cfg file.

Comment by scopus on 2014-12-30:
I have also modified "fixed_frame' in .cfg file to be "laser_link". But it failed still.

Comment by David Lu on 2014-12-30:
Is this still a problem, now that you've changed the frame to odom?

Comment by scopus on 2014-12-30:
It works now with "odom". I mean the "fixed_frame" both in cpp files and cfg file were changed to be "laser_link". then the package was re-built. In this case, it didn't work. I wonder why it failed with "laser_link". Thank you and Happy new year to you!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.