0
$\begingroup$

Rosanswers logo

Hello,

(sorry for my English, not my native language) Im using ROS Indigo on Ubuntu 14.04 and my goal is to estimate robot motion via visual odometry by using ROS. Im using usb_cam and image_proc to get image_rect which are used by mono_odometer in viso2_ros package. I also calibrated my camera with camera_calibration. My camera is located at height of 0.2m so I used static_transform publisher between /base_link and /head_camera where I set coord z to 0.2. I need to do some tests without robot, using only camera and estimate camera motion. My tests are quite easy, I just need to move camera forward by 1m and get result that camera`s location was moved by 1m and do the same with rotation by 90 degrees. For this easy tests I am just using rostopic echo /mono_odometer/odometry which contains header, pose and twists, but my problem is, that Im getting some data, which dont look right ... Can u please tell me what am I doing wrong and give me some guides to get right solution?

Thank you very much, Martin


Originally posted by Morho on ROS Answers with karma: 1 on 2014-12-21

Post score: 0


Original comments

Comment by Miquel Massot on 2015-01-03:
Hi Martin, what do you mean with data that "does not look right"? What is the problem? Is there too much error, displacement, rotation... ?

Comment by Morho on 2015-01-05:
Hi, just during pure moving forward I have sometimes error about 30% on X-axis and there is also error displacement rising on Y-axis and Z-axis. During rotation are data totally nonsense, mono_odometer evaluates rotation as move in every axis about few meters.

Comment by Morho on 2015-01-05:
And I also use wideangle web cam (120deg) and Im trying to avoid pure rotation ... Should I tune parameters in Matcher.h for matching? If yes, do you know how to tune them? Thanks

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

libviso2 is intended for high framerates ( >10 fps) on places with features. Is it possible that on the place you are doing the experiments there are not enough features? Do you see any message in the console of odometer lost? If so, try to move slowly or in a richer environment.


Originally posted by Miquel Massot with karma: 1471 on 2015-01-12

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.