0
$\begingroup$

Rosanswers logo

Hello, I am having to upgrade to hydro and in the process of getting my enviroment set up I ran into a stumbling block. ROS_VRPN_Client requires bullet3. After downloading bullet3 and making it I still get an erros when trying to run ROSMAKE on vrpn_client. This is the error I keep getting.

package/stack 'ros_vrpn_client' depends on non-existent package 'bullet' and rosdep claims that it is not a system dependency. Check the ROS_PACKAGE_PATH or try calling 'rosdep update

I understand why it wont compile, I need Bullet but the problem is I have downloaded it and have followed the steps by bullet to get it compiled. The question is, where am I doing things wrong at?

Any help will be appreciated.


Originally posted by TheHenshinger on ROS Answers with karma: 3 on 2014-12-11

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

There is a rosdep key for bullet which is defined on Precise. You should be able to resolve it if you run rosdep update.

That said, it looks like the packaged version of bullet on 12.04 is version 2.8, which isn't the version you want. In that case, you should probably just remove the dependency on bullet from your manifest.xml altogether.


Originally posted by ahendrix with karma: 47576 on 2014-12-11

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by TheHenshinger on 2014-12-19:
hmmm, I ran rosdep update with no luck.

How will removing the dependency in the manifest.xml file fix the problem?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.