Rosanswers logo

Hi all,

I have recently installed a UTM-30LX hokuyo laser scanner on my pioneer. Everything worked good except that I have noticed something strange with the measurements of the laser while visualising the /scan topic on rviz.

As you can see in the pic when an object is in-front of a wall ( at various angles/distances) there are some false measurements and basically is like ROS is thinking is one continuous object by getting some false readings between the end of the object and the wall (where it should be empty space). This is happening regardless of the material of the object or the wall. In the pic case, the wall is wood and the object is cardboard.

image description

I have tried both hokuyo_node and urg_node with a variety of settings, included the ones that are suggested and tested to work for utm-30lx. Unfortunately the robot is unable to navigate like that because the cost map thinks is an obstacle there.

Does anyone have an idea why this is happening?

Originally posted by Manolis Chiou on ROS Answers with karma: 70 on 2014-11-20

Post score: 0


1 Answer 1


Rosanswers logo

This is caused by the veiling effect near the edges of objects. The laser_filters package provides the ScanShadowsFilter to remove those points.

Originally posted by kmhallen with karma: 1416 on 2014-11-20

This answer was ACCEPTED on the original site

Post score: 4

Original comments

Comment by Manolis Chiou on 2014-11-21:
thanks that worked!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.