0
$\begingroup$

Rosanswers logo

I am trying to install and run openni_tracker on a turtlebot laptop running hydro. When I try to run the openni_tracker after installing it with sudo apt-get install ros-hydro-openni-tracker we get this error:

/opt/ros/hydro/lib/openni_tracker/openni_tracker: error while loading shared libraries: liborocos-kdl.so.1.3: cannot open shared object file: No such file or directory


Originally posted by ericjamesrose on ROS Answers with karma: 1 on 2014-11-19

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It looks like the version of the openni tracker that you're trying to install was built against a newer version of KDL. You should probably upgrade all of your installed packages to pull in the most recent build of KDL and upgrade all of the packages that might be built against the old version:

sudo apt-get dist-upgrade

Originally posted by ahendrix with karma: 47576 on 2014-11-19

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.