0
$\begingroup$

Rosanswers logo

Hi everyone,

I have just started with Ubuntu, ROS and Gazebo so I really do not know much yet. However, I really want to learn as much as possible and as fast as possible so please help me.

I am going through the tutorials for the turtlebot simulation on Gazebo after going through the tutorial from gazebosim. I can make the robot move with the command but I am having issues with the RViz parts. In the first tutorial, when I open RVIZ, to visualize my world in Gazebo, I have a warning for the image. It displays no image received. I can still see the obstacles added to the world with the point cloud. Do you know why I am not receiving any image?

USing Hydro and gazebo 1.9

Thanks


Originally posted by turtlebot_lille on ROS Answers with karma: 21 on 2014-11-13

Post score: 2

$\endgroup$

3 Answers 3

0
$\begingroup$

Rosanswers logo

It might be that the rviz config is connected to the wrong topic. See if there's another topic available to select for the image.


Originally posted by tfoote with karma: 58457 on 2015-10-26

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

tfoote, thanks for your answer. I had the same problem and used your advice.

  1. Firstly, I'd like to add more detailed answer.

    Edit the parameter "Image"->"Image Topic" to possible value (for example, "/camera/rgb/image_raw"). You can find possible values click on the drop-down list on the "Image"->"Image Topic". It works only for this session.

    If you want to make changes to all sessions, edit this parameter in the config: robot.rviz. You can find the path in File->Open Config. In robot.rviz find "Class: rviz/Image" and edit "Image Topic".

  2. Secondly, I'd like to add other decision. You can use current Topic (at least "/camera/rgb/image_rect_color"). Install "openni" and launch it:

    1. sudo apt-get install ros-indigo-openni-launch
    2. In a new terminal execute: roslaunch openni_launch openni.launch load_driver:=false depth_registration:=true

Originally posted by nampi with karma: 77 on 2015-10-27

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by tfoote on 2015-10-27:
@nampi Thanks for digging in. Could you look at submitting it upstream to the turtlebot_interactions repo. There might be some discussion about how to make it work for both simulation and the real robot but we should make it compatible for both.

$\endgroup$
0
$\begingroup$

Rosanswers logo

This is specific to Turtlebot3. The 'burger' model doesn't have a camera whereas the 'waffle_pi' does. I had to reset the model to waffle_pi to get all the camera related topics.


Originally posted by Shivendra with karma: 23 on 2020-04-02

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by trunc8 on 2020-07-03:
Thank you for this! I wish this information was included in beginner tutorials on Turtlebot3.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.