Rosanswers logo

I have started working with two prosilica cameras for stereo vision. At first I downloaded the driver package for prosilica camera driver. I developed two launch files for two cameras in syncin1 and in fixed rate mode. Now after launching the files both the cameras are working. I have checked using rqt as well

rosrun image_view image_view image:=stereo/left/image_raw

but the topic /stereo/disparity is not showing anything. If I try to view the disparity image using

rosrun image_view disparity_view image:=stereo/disparity

it pops a window but there is nothing. Even in rqt if i go for visualization in the topic list the /stereo/disparity topic is not in the list. I am really stuck in here. Any help will appreciable.

Thanks in advance.

Originally posted by Robot on ROS Answers with karma: 180 on 2014-11-11

Post score: 0


1 Answer 1


Rosanswers logo

Hi saptarshi,

first, you have to run stereo_image_proc and then calibrate the cameras with a chekerboard, as explained here. Once the calibration has been saved (or commited), then the disparity image should be available from the topic in stereo_image_proc.

I have a similar setup (two color GigE AVT Manta sync'd), and decided to implement a new driver using the new AVT API VIMBA. The ros node is available here. I'd be very grateful if you could give it a try.

Originally posted by Miquel Massot with karma: 1471 on 2014-11-11

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by Robot on 2014-11-12:
hey I have done the calibration and commit it. but still if i view the disparity image using "rosrun image_view disparity_view image:=/stereo/disparity" the pop-up window is empty. I have modified the disparity parameter as well but still it is not working.

Comment by Miquel Massot on 2014-11-14:
Can you show us your launchfile?

Comment by Miquel Massot on 2014-11-14:
Saptarshi, check that you are also receiving images from your right camera and that those and synchronized.

Comment by Robot on 2014-11-14:
thanks a lot... I have checked. we have to add _approximate_sync:=True and _queue_size:=10 arguments with the stereo_view node..


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.