0
$\begingroup$

Rosanswers logo

Do I need any drivers to run the kinect on ROS? I ran sudo apt-get install ros-indigo-openni* and it downloaded 5mb of files. Then I tried following the tutorial at the wiki but when I ran the first command it said "[ Info] ... No Devices Connected ..." . lsusb shows up with the xbox nui camera and audio and a microsoft device on bus 1.... I'm using the XBOX 360 kinect and power cord from microsoft... What am I doing wrong here? Thanks,

Update: I have a kinect model 1473. Does that make any difference

When I run hsoltani's answer I still get the no devices connected error


Originally posted by luketheduke on ROS Answers with karma: 285 on 2014-11-01

Post score: 0

$\endgroup$

3 Answers 3

0
$\begingroup$

Rosanswers logo

I tried a number of things, so not sure what the exact combo that made it work was, but I think this should work:

A) sudo apt-get install ROS-Indigo-OpenNI-Launch (probably similar to what you installed)

B) Use step 3 from this for the drivers: http://www.20papercups.net/programming/kinect-on-ubuntu-with-openni/

C) Play with it: http://wiki.ros.org/openni_launch/Tutorials/QuickStart

If that does work, please comment.


Originally posted by corb with karma: 339 on 2014-11-10

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by science00000 on 2017-03-01:
work for me, ubuntu 14.04 ros indigo

Comment by JarvisRobot on 2017-08-04:
work for me too, ubuntu 14.04 ros indigo But I start from step 2, or it will fail.

$\endgroup$
0
$\begingroup$

Rosanswers logo

What's the model number of your kinect? Kinect 1473 doesn't work with openni2. Remove ros-indigo-openni2-launch and ros-indigo-openni2-camera. Try to install ros-indigo-openni-launch and ros-indigo-openni-camera. Then following the tutorial and launch the OpenNI driver like this:

roslaunch openni_launch openni.launch


Originally posted by hsoltani with karma: 70 on 2014-11-11

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by luketheduke on 2015-02-24:
I tried that but it still doesn't work... What now?

$\endgroup$
0
$\begingroup$

Rosanswers logo

Hi!

Openni_launch does not work anymore under Indigo for Kinect , but freenect_launch does. So install freenect_launch and libfreenect :

sudo apt-get install libfreenect-dev

sudo apt-get install ros-indigo-freenect-launch

Then call :

roslaunch freenect_launch freenect.launch

If it still does not work , disconnect Kinect from usb and plug again.

One more thing , it didn't work for me when Kinect was connected through an USB 2.0 hub but directly in USB 3.0 input of pc.

Source: http://wiki.ros.org/openni2_launch

"This package contains launch files for using OpenNI-compliant devices in ROS. It supports the Asus Xtion, Xtion Pro, and multiple version of the Primesense 1.08 and 1.09 cameras. It does NOT support any versions of the Kinect. freenect_launch or openni_launch is the recommended package for using a Kinect with ROS."


Originally posted by Kaplan with karma: 81 on 2014-12-01

This answer was NOT ACCEPTED on the original site

Post score: 6


Original comments

Comment by luketheduke on 2014-12-02:
It still says no devices connected... A device made by microsoft with code: 045e:02c2 showed up when i executed lsusb.... any other ideas? Also when I run roslaunch freenect_launch freenect.launch I get No devices connected.... waiting for devices to connect

Comment by skywalker on 2015-03-18:
Actually it says that openni2 does not support any of Kinects. openni should support. btw. I was encountering with the same problem but freenect_launch solved it. I am able to get rgb and depth data On the other side I have to change lacun files which calls openni_launch as default with freenect

Comment by luketheduke on 2015-03-23:
To solve my problem I also had to install the avin2 drivers. That made it work. Thanks for all your help!

Comment by Nimisha on 2015-03-25:
Hi luketheduke. I am trying to interface kinect to ROS indigo and am facing similar problems. Could you please tell me the entire procedure all over so that i could know where i am going wrong.

Comment by luketheduke on 2015-03-25:
@Namisha I made a blog post detailing how I installed the necessary software. See it here http://goo.gl/zr3QiG.

Comment by soichirutk on 2015-04-03:
What I get afert luanching freenect is just the following message [INFO] [1428079238.372035547]: Stopping device RGB and Depth stream flush. And I don't know what does it means,so is still kinect having troubles ? Because I also run rviz, trying to see an image

Comment by skywalker on 2015-04-03:
I get same log, but it didn't affect anything. I can run RViz without problems. No idea why it comes out.

Comment by luketheduke on 2015-04-03:
@soichirutk I get the same thing as @skywalker. I don't have any problems with it. Just try restarting rviz if it still doesn't show up.

Comment by soichirutk on 2015-04-03:
Thank's @luketheduke and @skywalker, yes I could get a color image and depth image with ROS, and also I tried a code in python and it worked... maybe some errors with this code rosrun image_view image_view image:=/camera/rgb/image_color, as I'm new in ROS I will continue reading more

Comment by sony on 2015-04-22:
dear all I follow the tips but my Kinect still can not work [ INFO] Starting a 3s RGB and Depth stream flush. [ INFO] Opened 'Xbox NUI Camera' on bus 0:0 with serial number [ WARN] Could not find any compatible depth output mode for 1. Falling back to default depth output mode 1. what`s the probl

Comment by pnambiar on 2015-07-24:
I am trying to get the Kinect for windows (version 1) model 1517 work with ros I tried both reenect_stack and openni_kinect and I'm getting the error No devices connected.... waiting for devices to be connected. Will this proced work for model 1517 as well.

Comment by luketheduke on 2015-07-28:
@sony do you seem to be having problems viewing the depth stream or rgb image from the kinect? Because it seems that your device is connected but there may be some configuration issues...

Comment by luketheduke on 2015-07-28:
@pnambiar It seems that you have a driver problem... I made a guide on how to fix it, you can read it here: http://goo.gl/zr3QiG

Comment by adelleodel on 2015-10-31:
Hey, if libfreenect doesn't support skeleton tracking. What should i do as an indigo user? I want to make use for skeleton_tracker in openni, but u said i can't use it. What should i do then?

Comment by luketheduke on 2015-11-01:
I am not sure about which skeleton tracker package you are talking about, but on the Freenect FAQ's[], it says this:

"Does libfreenect have any skeleton tracking feature?

Skeleton tracking is higher-level than drivers and libfreenect is basically a low-level driver within OpenKinect."

Comment by luketheduke on 2015-11-01:
Freenect and LibFreenect only provide a driver to the Kinect. Openni, which has since been dissolved, provided the basic drivers and a few algorithms. So it is possible to do a skeleton tracker with Freenect but you will need to either implement an existing tracker, or write your own.

Comment by adelleodel on 2015-11-01:
Hmm.. the thing is.. i never had programming with image processing or such.. will it takes so much time? I need to run my friends old program ASAP. If i update my ROS to Jade or newer version, can i use the openni_*? Which way should i hv to do?

Comment by luketheduke on 2015-11-02:
You could possibly do it with OpenCV but it would take a lot of work. I reccomend that you open a new question here to get help and maybe upload the code to github, etc... BTW, you only need to do this if you have a kinect model 1473. All others work with openni, AFAIK

Comment by ani on 2017-05-23:
Thanks @Kaplan. As you suggested, freenect_launch works well on ros-indigo.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.