0
$\begingroup$

Rosanswers logo

Hello.

first of all let me say that all launch files I post here work on my PC, but not on pandaboard or parallella with Ubuntuarm Ros-hydro. I tried different launch files but my basic one is the following:

<node pkg="tf" type="static_transform_publisher"name="base_to_laser_broadcaster4"     
      args="0.0 0 0 0.0 0.0 0.0 /base_footprint/base_link 1" />                    
<node pkg="tf type="static_transform_publisher"name="base_to_laser_broadcaster3"    
      args="0.0 0 0 0.0 0.0 0.0 /base_link/laser_link 1" />                   
<arg name="geotiff_map_file_path" default="$(find hector_geotiff)/maps"/>         
<include file="$(find hector_mapping)/launch/mapping_default.launch"/>                     
<include file="$(find hector_geotiff)/launch/geotiff_mapper.launch">          
      <arg name="trajectory_source_frame_name" value="scanmatcher_frame"/>   
      <arg name="map_file_path" value="$(arg geotiff_map_file_path)"/>
</include> 

Even with this one I get

[ERROR] [1414485362.668347630]: Trajectory Server: Transform from /map to scanmatcher_frame failed: "map"     passed to lookupTransform argument target_frame does not exist. 

rqt_wtf gives me:

 Errors connecting to the following services: * service [/hector_geotiff_node/get_loggers] appears to be                 malfunctioning: Unable to communicate with service [/hector_geotiff_node/get_loggers],       address [  rosrpc://localhost:46397] * service [/hector_geotiff_node/set_logger_level] appears   to  be malfunctioning: Unable to communicate with service [/hector_geotiff_node/set_logger_level],    address               [rosrpc://localhost:46397]

but I can't make sense from it. Ideas what I'm missing?


Originally posted by Pilif on ROS Answers with karma: 1 on 2014-10-28

Post score: 0


Original comments

Comment by ahendrix on 2014-10-28:
Please format your launch file so that it is readable.

Comment by Pilif on 2014-10-28:
sorry, should be fixed now

Comment by bvbdort on 2014-10-28:
can you share frames.pdf from rosrun tf view_frames and rqt_graph.

Comment by Pilif on 2014-10-29:
sure - frames and graph

Comment by bvbdort on 2014-10-29:
Looks like scan matchiing is failed, if scan matching is success hector mapping will broadcast map to scanmatcher_frame. Give a try with test bag file .

Comment by Pilif on 2014-11-03:
@bvbdort I tried it - I get the same problem.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I suspect there's a node or nodes that are crashing or running very slowly. I would check the roslaunch output to make sure nothing is crashing, and I would check top to see if any of your nodes are using a lot of memory or CPU cycles.


Originally posted by ahendrix with karma: 47576 on 2014-10-28

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Pilif on 2014-10-29:
No nodes are crashing. In roslaunch there is only the error about the Trajectory Server. Here is the htop output. Can, in general, hector_slam be run from a ARMboard ?

Comment by ahendrix on 2014-10-29:
ARM cpus tend to be slower than their x86 counterparts. That said, it looks like you're using all of your CPU cycles. Given that your static transform publishers are using a combined total of 110% of one core, you may want to consider reducing the static transform rate.

Comment by ahendrix on 2014-10-29:
You may also want to consider switching to the robot_state_publisher , which uses a single node for publishing transforms and future-dates them, which can prevent transform latency problems.

Comment by Pilif on 2014-11-03:
@ahendrix Thank you will definitely try robot_state_publisher.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.