0
$\begingroup$

Rosanswers logo

Hello,

I want to use rviz with a webcam. I'm not able to launch rviz if LIBGL_ALWAYS_SOFTWARE is not defined. I need to do "export LIBGL_ALWAYS_SOFTWARE=0". If I go out of rviz and I want to use it again it will not work. Sometimes it will work again but I need to modify LIBGL_ALWAYS_SOFTWARE (sometimes 0 and sometimes work only with 1 ?).

But at this time, the biggest problem is that all menu have black background. The center part and the bottom are grey, so no problem to read text on it. But the left part, the right part and the upper part have black background. I can see there are some menus, but impossible to read. In the upper part, I have just icons which I can see.

So I change theme, I tested with Ubuntu Interface, Cinnamon Interface, I used with 1 external monitor so I disconnected it but ... it's always the same.

So my question is simple: how can I change the background of these black parts before launching rviz ? Or may be there is another problem ?

Thanks for reply.

Goupil

Configuration: Zenbook UX32VD (only graphics from Intel I7) / Ubuntu 14.04 / ROS Indigo / OpenGl 4.4 /rviz 1.11.3

Edit: Tested after switching to Nvidia 620m card. It's the same, black background for menus. I remove ~/.rviz, same problem. To launch rviz it seems that it works sometimes (1 times / 3 tries) with intel graphics but it launches more often with Nvidia. It's independant of the value of LIBGL_ALWAYS_SOFTWARE (but it seems slower when this variable is on 1).


Originally posted by goupil35000 on ROS Answers with karma: 113 on 2014-10-06

Post score: 1

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I can strongly suggest you to remove the nouveau driver coming as default with ubuntu and install the closed sources driver from Nvindia. Here an awesome tutorial. I solved problem like that removing the nouveau and installing the Nvidia propretary drivers.

Regards


Originally posted by Andromeda with karma: 893 on 2014-10-13

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$
0
$\begingroup$

Rosanswers logo

I had the same problem running Cinnamon on Ubuntu 14.04 with my GeForce GT 650M (Mac Edition). I fixed it by running:

  gtk-theme-config

and then turning "Custom Panel Colors" to on.

Theme Configuration Panel


Originally posted by rand with karma: 38 on 2015-01-21

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by spurs9528 on 2017-03-21:
That's great. Thank you very much!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.