0
$\begingroup$

Rosanswers logo

Hello, I just tried installing ros-indigo-desktop-full on my 64-bit Ubuntu 14.04 system, and the installation of libopenni-sensor-pointclouds0 failed with:

Setting up libopenni-sensor-pointclouds0 (5.1.0.41.1-1) ...
Installing new version of config file /etc/openni/GlobalDefaults.ini ...
niReg: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory
dpkg: error processing package libopenni-sensor-pointclouds0 (--configure):
 subprocess installed post-installation script returned error exit status 127

It seems that this issue is not unheard of, and this random web page page suggested that I

sudo ln -s /lib/x86_64-linux-gnu/libudev.so.1.3.5 /usr/lib/libudev.so.0

which I did, and which solved (for the moment) my installation problem. Needless to say, this feels like the worst way I could make this problem go away. As the libopenni-sensor-pointclouds0 package is maintained by Ubuntu folks (as opposed to ROS folks), I went ahead and opened this bug report to see what they would say.

I guess I should get to my question... :-)

Has anybody else had this problem?

In the mean time, if somebody else has this same problem and stumbles across this question, that person will have as much to go on as I do right now.

In the spirit of full disclosure, I just upgraded my 12.04 Ubuntu to 14.04. Perhaps something went a little flakey in that upgrade. I dunno.


Originally posted by wpd on ROS Answers with karma: 249 on 2014-09-30

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Similar question http://answers.ros.org/question/193581/libopenni-sensor-primesense0-conflict/


Originally posted by tonybaltovski with karma: 2549 on 2014-09-30

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by wpd on 2014-10-01:
The questions are similar, and both highlight that something seems a little broken, or misunderstood, with libopenni-sensor-pointclouds0, but that question highlights a Ubuntu package conflict, whereas mine highlights a broken installation (which may have been self-induced).

Comment by tfoote on 2014-11-10:
The issue was resolved here: https://github.com/ros/rosdistro/issues/3986 If you're in the broken state the easiest thing to get unbroken is to use the force overwrite option in the answer. And then remove the older packages and make sure you've got the latest version which should conflict correctly

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.