0
$\begingroup$

Rosanswers logo

I am trying to build the AR tag detector package ar_track_alavar on Odroid U3 running ROS hydro on Lubuntu 13.04 Running catkin_make after cloning the package gives me the following error :

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a package configuration file provided by "tf" with any of the following names:

tfConfig.cmake
tf-config.cmake

Add the installation prefix of "tf" to CMAKE_PREFIX_PATH or set "tf_DIR" to a directory containing one of the above files. If "tf" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): ar_track_alvar/CMakeLists.txt:10 (find_package)

-- Configuring incomplete, errors occurred! Invoking "cmake" failed

Can someone please explain how to resolve this error?


Originally posted by rookie on ROS Answers with karma: 15 on 2014-09-30

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is a standard CMake error message telling you that it can not find tf. You need to install the missing dependencies either using rosdep or by installing the missing packages manually (in this case ros-hydro-tf).


Originally posted by Dirk Thomas with karma: 16276 on 2014-09-30

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by rookie on 2014-10-02:
Thanks.. i installed this package and catkin_make worked ! But I faced a weird problem that it gets stuck at around 22% and my Odroid hangs..probably the CPU usage is shooting up, something that has never happened before..I tried this twice but with the same result :/

Comment by spottybadrabbit on 2016-08-10:
Check out this Odroid image http://forum.odroid.com/viewtopic.php?f=95&t=16149

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.