0
$\begingroup$

Rosanswers logo

After running $ rosrun rqt_graph rqt_graph

i get the following error msg:

PluginHandlerDirect._restore_settings() plugin "rqt_graph/RosGraph#0" raised an exception:
Traceback (most recent call last):
  File "/opt/ros/indigo/lib/python2.7/dist-packages/qt_gui/plugin_handler_direct.py", line 116, in _restore_settings
    self._plugin.restore_settings(plugin_settings_plugin, instance_settings_plugin)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 202, in restore_settings
    self._refresh_rosgraph()
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 226, in _refresh_rosgraph
    self._update_graph_view(self._generate_dotcode())
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 259, in _update_graph_view
    self._redraw_graph_view()
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 292, in _redraw_graph_view
    same_label_siblings=True)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/qt_dotgraph/dot_to_qt.py", line 254, in dotcode_to_qt_items
    subgraph_nodeitem = self.getNodeItemForSubgraph(subgraph, highlight_level)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/qt_dotgraph/dot_to_qt.py", line 83, in getNodeItemForSubgraph
    bb = subgraph.attr['bb'].strip('"').split(',')
KeyError: 'bb'

Originally posted by Tomaszz on ROS Answers with karma: 33 on 2014-09-16

Post score: 0


Original comments

Comment by Dirk Thomas on 2014-09-18:
What version of these two packages do you use: rqt_graph and qt_dotgraph? Also please provide more information since you are likely doing more than what you described. E.g. which packages did you try to visualize in the graph?

Comment by Tomaszz on 2014-09-19:
Well, I'm not sure what do you mean by version of rqt_graph. I use ROS Indigo. Problems with rqt_graph started when using VREP together with ROS. For the first time it crashed when I played the simulation on VREP. Officially VREP doesn't support ROS Indigo. Now each rqt_graph run fails.

Comment by Dirk Thomas on 2014-09-19:
With "version" I mean the version of the Debian package you have installed. Please run "dpkg -l | grep rqt-graph" and "dpkg -l | grep qt-dotgraph" and post the result. My second question was: which packages did you try to visualize in the graph?

Comment by Tomaszz on 2014-09-20:
1/ ros-indigo-rqt-graph 0.3.9-0trusty-20140905-0110-+0000 amd64 ros-indigo-qt-dotgraph 0.2.26-0trusty-20140819-0222-+0000 amd64

2/ i tried to visualize vrep tutorials packages "ros_bubble_rob", "vrep_joy" etc

actually now it works fine :P I have restarted my laptop

Comment by Robopija on 2014-09-26:
I get exactly the same error message. I have ros-indigo-rqt-graph 0.3.9-0trusty-20140905-0309-+0000 i386 and ros-indigo-qt-dotgraph 0.2.26-0trusty-20140819-0326-+0000 i386, i don't use VREP. This happens even if no ros nodes are running, just a roscore.

Comment by VinceDietrich on 2015-02-19:
I have the same problem. Restarting Ubuntu helps at first, but error came back. Installing ros-indigo-qt-gui-app and ros-indigo-qt-gui-core did not help for me so far.

ros-indigo-rqt-graph 0.3.10-0trusty-20141230-0525-+0000 amd64 ros-indigo-qt-dotgraph 0.2.26-0trusty-20141230-0049-+0000 amd64

Comment by Dirk Thomas on 2015-02-19:
If anybody could come up with a minimal example to reproduce the issue it might be feasible to fix the problem.

Comment by Will Chamberlain on 2015-02-26:
Hello: I get the same problem. My versions are

ii ros-indigo-rqt-graph 0.3.10-0trusty-20141230-0525-+0000 amd64

ii ros-indigo-qt-dotgraph 0.2.26-0trusty-20141230-0049-+0000 amd64

and I am trying to use rqt_graph as on A Gentle Introduction to ROS (J.M. O'Kane) p24

Comment by Will Chamberlain on 2015-02-26:
(cont): rosnode list

lists

/rosout

/teleop_turtle

/turtlesim

Workaround/clue: I just found that unticking 'Hide Debug' clears the error and displays the graph. Ticking 'Hide Debug' gives the error message again.

Comment by gocarlos on 2015-03-11:
happen here too... nothing open and still crashing. only two very small packages in the WS

Comment by silverArgon on 2015-04-15:
Hi, im having the same problem. Tried both install ros-indigo-qt-gui-app and ros-indigo-qt-gui-core and restarting, but with no result. Any guess to what it could be?

Comment by Dirk Thomas on 2015-04-23:
As before: if anybody could come up with a minimal example (using ROS packages) to reproduce the issue it might be feasible to find the source of the problem.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I can vouch for Tomaszz, restarting Ubuntu after installing rqt_graph and plugins fixes this issue.


Originally posted by DataCrusader21 with karma: 16 on 2014-09-30

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.