Rosanswers logo

I am following this tutorial:


When I enter this command, rosrun stage stageros roomba_isr_floor0.world

it gives this error

[rosrun] Couldn't find executable named stageros below /opt/ros/hydro/share/stage

Originally posted by tonyParker on ROS Answers with karma: 377 on 2014-09-12

Post score: 2

Original comments

Comment by Akali on 2015-01-12:
I had same problem bro. Did you solve that error?

Comment by marcobecerrap on 2015-07-29:
Does anyone knows how to solve this? I'm having the same error here... I'm trying to run stage with a simple command: $ rosrun stage_ros stageros ./map01_Room.world But I get this error: [rosrun] Couldn't find executable named stageros below /opt/ros/indigo/share/stage_ros


1 Answer 1


Rosanswers logo

You've got the package name wrong, it's stage_ros not stageros and the executable name is stageros not stage_ros (confusing I know). When I run that command:

$ rosrun stage stage_ros roomba_isr_floor0.world

On my Ubuntu 12.04.5 Hydro install I get an error that it cannot find the world file (expected) but if does find and run stageros:

william@ubuntu:~$ rosrun stage_ros stageros roomba_isr_floor0.world
[FATAL] [1438216243.460273767]: The world file roomba_isr_floor0.world does not exist.
 [Loading roomba_isr_floor0.world]err: unable to open world file roomba_isr_floor0.world : No such file or directory (/tmp/buildd/ros-hydro-stage-4.1.1-6precise-20141231-2201/libstage/worldfile.cc Load)

Stage: User closed window

It looks like that tutorial needs to be updated. If you figure out what it should be please feel free to update the tutorial.

Originally posted by William with karma: 17335 on 2015-07-29

This answer was ACCEPTED on the original site

Post score: 3

Original comments

Comment by Will Chamberlain on 2018-03-26:
Update to <node pkg="stage_ros" type="stageros" . Related:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.