0
$\begingroup$

Rosanswers logo

I used the source code method to build the "Quadrotor outdoor flight demo" as the ros-hydro-hector-quadrotor-demo cannot be located. However, I cannot proceed with installation as I always encountered the following error message when doing "catkin_make", as shown in the following. The OS I am using is Ubuntu 14.04 and ROS Indigo.

viki@c3po:~hector_quadrotor_tutorial$ catkin_make

........
........
-- Eigen found (include: /usr/include/eigen3)
-- +++ processing catkin package: 'hector_geotiff_plugins'
-- ==> add_subdirectory(hector_slam/hector_geotiff_plugins)
-- Using these message generators: gencpp;genlisp;genpy
-- +++ processing catkin package: 'hector_marker_drawing'
-- ==> add_subdirectory(hector_slam/hector_marker_drawing)
-- Eigen found (include: /usr/include/eigen3)
-- +++ processing catkin package: 'hector_quadrotor_controller'
-- ==> add_subdirectory(hector_quadrotor/hector_quadrotor_controller)
-- Using these message generators: gencpp;genlisp;genpy
CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
Could not find a package configuration file provided by
"hardware_interface" with any of the following names:

hardware_interfaceConfig.cmake
hardware_interface-config.cmake

Add the installation prefix of "hardware_interface" to CMAKE_PREFIX_PATH or
set "hardware_interface_DIR" to a directory containing one of the above
files. If "hardware_interface" provides a separate development package or
SDK, be sure it has been installed.
Call Stack (most recent call first):
hector_quadrotor/hector_quadrotor_controller/CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/viki/hector_quadrotor_tutorial/build/CMakeFiles/CMakeOutput.log".
See also "/home/viki/hector_quadrotor_tutorial/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed
...

Could you help fix this? Thanks.


Originally posted by UAS on ROS Answers with karma: 1 on 2014-09-11

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Try with:

sudo apt-get install ros-indigo-hector-*

I had similar a similar problem


Originally posted by Andromeda with karma: 893 on 2014-09-11

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.