Rosanswers logo

Hi ROS Users,

The ROS community has grown tremendously over the last 2 years, and it is good to be part of this growing community. Previously I tried to install ROS (Groovy) on Raspberry Pi using this tutorial and it was successful (Debian installation). I also understand that there is Hydro Installation (installation from Source) which requires lot of time for compilation. So now My questions are,

  1. how should one proceed to install the latest version of ROS (For eg. Indigo ) on Raspberry Pi from source?
  2. how to create a ROS Indigo debian release, after installing from source (I would like to try this)?

it is also much appreciated if someone can give pointers to a debian installation of Hydro on Raspberry pi. Thanks again, and thanks to the whole community,

Best Regards,


Originally posted by MKI on ROS Answers with karma: 246 on 2014-09-09

Post score: 1

Original comments

Comment by Airuno2L on 2014-09-09:
It would be nice if there was a collection of images somewhere for common hardware such as the Raspberry Pi and Beaglebone Black with Ubuntu + ROS preinstalled.

Comment by ccapriotti on 2014-09-09:
This has already been discussed on other topics. Turns out the cost (money and man hours) to keep this kind of images AND maintain binaries+repositories is high.

Not practical in the end. Community goals do not lean that way. (which is a nice way to say that those platforms are not that popular).


2 Answers 2


Rosanswers logo

I think I've worked out many of the problems with getting Indigo installed on the Raspberry Pi. I've written up some installation instructions here: http://wiki.ros.org/ROSberryPi/Installing%20ROS%20Indigo%20on%20Raspberry%20Pi.

If you have a chance to try it out, I'd appreciate if you let me know if there are any problems and I'll try to keep it updated.

Originally posted by awilson with karma: 231 on 2014-10-21

This answer was ACCEPTED on the original site

Post score: 5

Original comments

Comment by MKI on 2014-10-21:
Sure, will try it out over the weekend ... thank you for the update.

Comment by MKI on 2014-10-23:
@awilson Hi, Just installed bare-bones version of Indigo on Rpi, I did not overcome any problems during the installation. Truly nice work ... Thank you. Could you also leave an update as to how to install individual packages from source and also how to uninstall the same? Thanks again.

Comment by awilson on 2014-10-23:
@MuraliKrishnan Great! I added a section at the end on adding individual packages to the workspace. I'm actually not sure the best way to uninstall a single package - to uninstall ros completely, you can just delete /opt/ros/indigo.

Comment by epascual on 2014-11-02:
I followed it, and it works fine until step 2.2.2 (rosdep install). It fails installing python-catkin-pkg and thus dependants, saying : "python-catkin-pkg : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable" Of course Python is here (2.6, 2.7.3 and 3). Thanks in advance for any clue.

Comment by awilson on 2014-11-02:
@epascual Hmm, I'm not sure why I didn't run into that, but I would try to install catkin_pkg using pip (sudo pip install -u catkin_pkg) and then rerun rosdep. If there's still an error, add -r to the rosdep command to ignore install errors and that may work. What variant are you installing?

Comment by epascual on 2014-11-03:
@awilson Thanks a lot for your quick reply. I could bypass the problem by removing the "python:any" dependencies in /var/lib/dpkg/status and the whole process went fine. I'm installing the basic ros_comm variant. Could it be some change in the ubuntu repo the "python:any" depends clause points to?

Comment by awilson on 2014-11-03:
@epascual Glad you got it working. I think python:any was very recently added and the version of apt on wheezy doesn't handle it (https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1271237). So, your fix is fine, or it can be ignored because those packages are installed on pip.

Comment by epascual on 2014-11-03:
@awilson I couldn't find any doc on the meaning of the :any suffix BTW. Maybe the procedure described in this article should mention to install these packages using pip and not letting rosdep trying to do the job. Or am I misunderstanding something ?

Comment by MattHoward on 2015-04-17:
Any updates on this? I tried installing via pip, editing /var/lib/dpkg/status (which didn't have any references to python:any), and adding ignore error flags but nothing seems to work.

Comment by epascual on 2015-04-18:
@MattHoward I successfully managed to finalize the process, and get a working environment. It's documented (with all console traces) here : http://www.pobot.org/ROS-sur-RaspberryPi.html Sorry for this, it's written in French. But Google Translate can help, and traces are in English ;)

Comment by MattHoward on 2015-04-19:
@epascual Thanks for the help. I followed your tutorial (using both Google Translate and my high school understanding of French) but ran into the same issue I previously had. My /var/lib/dpkg/status (posted here https://gist.github.com/moward/62b35aa6257e9fd05ad4) had no traces of python:any. :(

Comment by epascual on 2015-04-19:
@MattHoward Sorry it couldn't help you more :/ Which error do you encounter exactly ? The same dependency as I got, or something else ?

Comment by MattHoward on 2015-04-19:
Yeah, I was have the issue with "python:any". I'm trying now with Ubuntu on RPi 2 (https://wiki.ubuntu.com/ARM/RaspberryPi) however.

Comment by epascual on 2015-04-19:
It should be a better option anyway, since ROS was a bit sluggish on the RasPi. Having several core can help. Not yet tested.

Comment by MattHoward on 2015-04-21:
I can confirm that you can install ROS on Ubuntu with the RPi 2 following the official ROS installation guide, no problems.

Comment by epascual on 2015-04-22:
Fine, this will simplify the life a lot :)


Rosanswers logo

Hi There,

Well, I tried this long, confusing, procedure and I was able to get Hydro on my RPi wheezy image. below are the steps I followed: (Please correct me if I did something wrong)

  1. Resizing the RPi image, well I used a 16Gb SD-card and was able to expand the file system on my Rpi hardware, using the sudo raspi-config utility. (My Idea was, to boot with as much memory as I could get).

  2. Getting the expanded RPi image on to my PC (Ubuntu 14.04). with the command sudo dd if=/dev/sdx/ of=/<path-to-my-image.img> (The Idea again is, not to use RPi hardware to perform source installation--->as it takes very long time)

  3. To boot the copied .img file in step 2 with QEMU (ARM Emulator). As mentioned in the previous answer above. (encountered a small problem here with the latest RPi image dated 09-09-2014). But I was able to boot into the RPi desktop.

  4. Following the ROS Hydro Source installation.I was able to complete the ROS installation and also could run the roscore on the QEMU terminal. (But with the exception that I was not able to install separate new packages and further steps were unsuccessful).

  5. The Last step is to get the image with ROS Hydro back onto the SD-Card with command, sudo dd if=<path-of-the-image-file-with-ROS Hydro> of=/dev/sdx ( step-2 reversed ). And ... I was NOT able to get the image run properly on Rpi hardware.

So, requesting ROS-Pi users who have already done this successfully to shed some light on this procedure, mentioned above. I spent the whole week with the emulation thing and could not get it to run on the actual hardware.

Thanks again,


UPDATE 1: I am using raspberry Pi B+ Hardware, many old distributions won't even boot on the new hardware. During the boot, I also encountered a problem of "missing kernel (ERROR) modules" with the old dist of wheezy(after performing above steps). Guess, this info might be helpful.

UPDATE 2: Hydro installation (debian) is available, I am getting dependency error when trying to perform this installation. to be more specific, I am not able to fully resolve the dependency with the command `

rosdep install --from-paths src --ignore-src --rosdistro hydro -y -r --os=debian:wheezy

` Anyone else who have done this please share your experiences. Also please let me know if you were able to do this successfully.

Originally posted by MKI with karma: 246 on 2014-09-19

This answer was NOT ACCEPTED on the original site

Post score: 1


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.