0
$\begingroup$

Rosanswers logo

Hello,

When we run move_base with dwa_local_planner, doing a rostopic list shows a topic named /move_base/DWAPlannerROS/trajectory_cloud, and another named /move_base/DWAPlannerROS/cost_cloud. However, nothing ever seems to get posted to these topics, even when there's an active nav goal in play. Should we be seeing output on these topics? We're debugging some strange behavior and would sure like to see what the planner is thinking.

Thanks,

Rick


Originally posted by Rick Armstrong on ROS Answers with karma: 567 on 2014-09-07

Post score: 0


Original comments

Comment by ahendrix on 2014-09-07:
I think there are parameters that you have to set to enable these topics.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

If you want to visualize the trajectory cloud and the cost cloud, you have to set the publish_traj_pc and publish_cost_grid_pc parameters respectively. These aren't dynamic_reconfigure parameters, so you'll have to set them directly in your local planner parameters.

This isn't well documented. I had to go to the source to find the relevant parameters: https://github.com/ros-planning/navigation/blob/ab3cdff51fa062845be8da4cf1e58f5fc56abab9/dwa_local_planner/src/dwa_planner.cpp#L154-L163


Originally posted by ahendrix with karma: 47576 on 2014-09-07

This answer was ACCEPTED on the original site

Post score: 4


Original comments

Comment by Rick Armstrong on 2014-09-09:
Great, thanks Austin!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.