0
$\begingroup$

Rosanswers logo

Hello everybody! I have a problem: I'm running amcl and navigation stack on husky in a empty room. If I add some obstacles in the room the global costmap will update but unfortunately the odom frame will have a wrong position. Can somebody help me please? I'm using hydro on ubuntu 12.04lts


Originally posted by alex920a on ROS Answers with karma: 35 on 2014-09-05

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Which map are you using ? if your map is for empty room and if you use amcl for room with obstacles localization will not be accurate. if your obstacles are moving at high rate and dont cover most of the view of sensor, amcl gives sufficient result which is not same if obstacle are static or very slow and big.


Originally posted by bvbdort with karma: 3034 on 2014-09-05

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by alex920a on 2014-09-06:
I'm using a static map of an empty room created with gmapping. Now I add to the stage some obstacles and trying moving the robot, but it's position will jump around and localization will not be accurated. Any suggestion? Should I use laser scan matcher instead of robot pose ekf?

Comment by bvbdort on 2014-09-06:
You need to update map with obstacle for correct localization. Currently no packages for available this. this topic is still in research. Google "localization in changing environments" for some papers.

Comment by alex920a on 2014-09-06:
So with robot pose ekf and laserscan matcher the position will always fail?

Comment by bvbdort on 2014-09-06:
if you know initial position, you can use robot pose ekf and laserscan matcher

Comment by alex920a on 2014-09-06:
I'll try and let you know!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.