0
$\begingroup$

Rosanswers logo

Hi,

I have been trying to make ROS Indigo work with Gazebo 4.0.0 so I installed a full desktop ROS (ros-indigo-desktop-full) first on a fresh Ubuntu 14.04.1 LTS (Trusty Tahr) and then installed Gazebo 4.0.0 (Online Install). Both seem to work fine by themselves but when I try to install:

sudo apt-get install ros-indigo-gazebo-ros-pkgs ros-indigo-gazebo-ros-control

I get the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 ros-indigo-gazebo-ros-control : Depends: gazebo2 but it is not going to be installed
                                 Depends: libsdformat1 but it is not going to be installed
                                 Depends: ros-indigo-gazebo-ros but it is not going to be installed
 ros-indigo-gazebo-ros-pkgs : Depends: ros-indigo-gazebo-plugins but it is not going to be installed
                              Depends: ros-indigo-gazebo-ros but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What could the problem be? Do I have to use a different version of Gazebo?

Thanks


Originally posted by rmoreno on ROS Answers with karma: 31 on 2014-08-28

Post score: 3

$\endgroup$

4 Answers 4

0
$\begingroup$

Rosanswers logo

If you scroll down to "Project Status" on this page, you'll see that Gazebo 2.2 is the recommended version to use with ROS Indigo (ROS I).


Originally posted by Airuno2L with karma: 3460 on 2014-08-28

This answer was ACCEPTED on the original site

Post score: 5


Original comments

Comment by rmoreno on 2014-08-28:
Thanks Airuno2L do I need to remove Gazebo 4 to install Gazebo 2.2? how can I completely remove Gazebo 4 from Ubuntu?

Comment by Airuno2L on 2014-08-28:
As mentioned here, try:sudo apt-get remove gazebo4

$\endgroup$
0
$\begingroup$

Rosanswers logo

I ran into the same issue attempting to install ros-indigo-gazebo-ros: I'd previously been working through the Gazebo tutorials and had installed Gazebo 4, per the instructions. Then came to realize that Indigo needs Gazebo 2, as explained here. As a previous post mentioned, you need to remove Gazebo 4 and install Gazebo 2:

sudo apt-get remove gazebo4
sudo apt-get install libsdformat1
sudo apt-get install gazebo2

Not sure if the second step was actually necessary; I was just chasing the dependency warnings. Hope that helps.

Rick


Originally posted by Rick Armstrong with karma: 567 on 2014-08-31

This answer was NOT ACCEPTED on the original site

Post score: 4


Original comments

Comment by rmoreno on 2014-09-02:
Hi, I uninstalled gazebo4 using "sudo apt-get remove gazebo4" and then tried to install gazebo2 by following the tutorials on the gazebo homepage but ran into a similar dependency problem so I actually reinstalled Ubuntu and ROS and realized that gazebo2 is already installed with ROS.

$\endgroup$
0
$\begingroup$

Rosanswers logo

This is what I see in my Ubuntu 14.04:

~$ dpkg -s ros-indigo-gazebo
ros-indigo-gazebo4-msgs
ros-indigo-gazebo4-plugins
ros-indigo-gazebo4-prerelease-msgs
ros-indigo-gazebo4-prerelease-plugins
ros-indigo-gazebo4-prerelease-ros
ros-indigo-gazebo4-prerelease-ros-control
ros-indigo-gazebo4-prerelease-ros-pkgs
ros-indigo-gazebo4-ros
ros-indigo-gazebo4-ros-control
ros-indigo-gazebo4-ros-pkgs
ros-indigo-gazebo-msgs
ros-indigo-gazebo-plugins
ros-indigo-gazebo-ros
ros-indigo-gazebo-ros-control
ros-indigo-gazebo-ros-pkgs

So it seems there are some indigo-gazebo4 packages. Did you try that (like apt-get remove ros-indigo-gazebo-* && apt-get install ros-indigo-gazebo4-*)?

I don't wanna try and hassle my own system, though, so sorry for I haven't tried that before posting the answer.


Originally posted by peci1 with karma: 1366 on 2014-09-02

This answer was NOT ACCEPTED on the original site

Post score: 2

$\endgroup$
0
$\begingroup$

Rosanswers logo

It should be possible , follow below link:

http://gazebosim.org/tutorials/?tut=ros_wrapper_versions#UsingaspecificGazeboversionwithROS


Originally posted by Mos with karma: 28 on 2015-04-11

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.