Rosanswers logo

What is the right way to setup Xtion Pro Live with Ubuntu 14.04? (later on I wanrt to use it with ROS) All How-To's found in internet refer to http://openni.org which is down. The new site for openNI2 is http://structure.io/openni but the information provieded there does not help me. I tried many things but seems to be that I'm to stupid to get it to work. What I'm doing wrong, what should I do?

What do I need? openNI1 or openNI2? Do I need to install with apt-get or build from source. Do I need to install this sensor driver: https://github.com/PrimeSense/Sensor (building fails for some reason). I'm totally desperate and confused due to the both version 1 and 2 from openNI.

// Here is my connected sensor

pat@hostx:~/Sensor$ lsusb | grep ASUS Bus 002 Device 004: ID 1d27:0601 ASUS

// Here is the sample I used

pat@hostx:~/OpenNI-Linux-x64-2.2/Samples/Bin$ ./SimpleRead Couldn't open device DeviceOpen using default: no devices found

Originally posted by Pat on ROS Answers with karma: 62 on 2014-08-16

Post score: 1


1 Answer 1


Rosanswers logo

Xtion 0601 runs using openni2, and 0600 runs using openni. If you want to use the former with ROS, let the openni2_launch wrapper run the driver and setup all the topics for you. It will also install all the correct dependencies:

sudo apt-get install ros-hydro-openni2-launch

If you're looking for Openni2 specific documentation, it's now hosted by Occipital (http://structure.io/openni).

Originally posted by paulbovbel with karma: 4518 on 2014-08-16

This answer was ACCEPTED on the original site

Post score: 0

Original comments

Comment by Pat on 2014-08-16:
THX sudo apt-get install ros-indigo-openni2-launch solved the issue for ID 1d27:0601. Then afterwards roslaunch openni2_launch openni2.launch

Comment by Andrew.A on 2014-10-29:
I'm trying to set up an rgb stream to my web browser using mjpeg_server and openni2 with Asus Xtion Pro Live. I ran roslaunch openni2_launch openni2.launch,rosrun mjpeg_server mjpeg_server, but I can't see anything on my web browser when I type in the url http://myurl.com:port/image_topic. Help!

Comment by paulbovbel on 2014-10-29:
Please open a new question instead of doing this. Include any error/debug output, your distro and hardware setup.

Comment by Andrew.A on 2014-10-29:
Please see http://answers.ros.org/question/196270/stream-asus-xtion-pro-live-rgb-with-openni2-and-mjpeg_server/ !

Comment by VinceDietrich on 2015-06-25:
My 0600 xtion only works with openni2, but not with openni


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.