0
$\begingroup$

Rosanswers logo

Hello, I have a non holonomic robot, "Seekur Jr." I set up the navigation stack, and I am using TrajectoryPlannerROS as a base local planner, with DWA set to true. The path planning works fine but I would like to enhance it more. As you can see in the video the re-planned path by the robot after it sees the obstacle doesn't consider the dimensions of the robot. It doesn't directly avoid the obstacle and it keeps on rotating to decide on the path. I have been tuning the parameters and I think the problem is there but am not sure which one is directly connected to this issue. Please guide me on this issue. I'd be glad and thankful to your suggestions.

http://www.youtube.com/watch?v=u35uZr1yFNw


Originally posted by AmiraJr on ROS Answers with karma: 28 on 2014-08-13

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Okay update I fixed the rotation problem by changing the inflation parameter. I increased the value from 0.55 to 1.0 and the obstacle avoidance became better.


Originally posted by AmiraJr with karma: 28 on 2014-08-14

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.