0
$\begingroup$

Rosanswers logo

I have installed the software like it is said in the page.

my system info is:

  • ubuntu 12.04
  • ros hydro
  • gazebo 1.9

However when i try to run it:

roslaunch turtlebot_gazebo turtlebot_empty_world.launch

gazebo crashes when he should spawn the bot. The log message i get when this happens is:

Dbg Plugin model name: mobile_base [ INFO] [1406225474.476679853, 0.410000000]: Will publish tf. [mobile_base] [ INFO] [1406225474.485497179, 0.410000000]: GazeboRosKobuki plugin ready to go! [mobile_base] [ INFO] [1406225474.496429589, 0.430000000]: Physics dynamic reconfigure ready. [spawn_turtlebot_model-4] process has finished cleanly log file: /home/samper/.ros/log/e4873b52-135d-11e4-bbd0-109add68f52e/spawn_turtlebot_model-4*.log Segmentation fault (core dumped) [gazebo_gui-3] process has died [pid 25180, exit code 139, cmd /opt/ros/hydro/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/samper/.ros/log/e4873b52-135d-11e4-bbd0-109add68f52e/gazebo_gui-3.log]. log file: /home/samper/.ros/log/e4873b52-135d-11e4-bbd0-109add68f52e/gazebo_gui-3*.log

I don't know why it is happening, other urdf models like shadow hand and arm are working pretty nice.

------------- EDIT -------------

when i check the log files i get this information:

[rospy.client][INFO] 2014-07-24 20:11:12,989: init_node, name[/spawn_turtlebot_model], pid[25187]

[xmlrpc][INFO] 2014-07-24 20:11:12,989: XML-RPC server binding to 0.0.0.0:0

[xmlrpc][INFO] 2014-07-24 20:11:12,990: Started XML-RPC server [http ://samper-MacBookPro:46217/]

[rospy.init][INFO] 2014-07-24 20:11:12,990: ROS Slave URI: [http ://samper-MacBookPro:46217/]

[rospy.impl.masterslave][INFO] 2014-07-24 20:11:12,990: _ready: http ://samper-MacBookPro:46217/

[rospy.registration][INFO] 2014-07-24 20:11:12,991: Registering with master node http ://localhost:11311

[xmlrpc][INFO] 2014-07-24 20:11:12,991: xml rpc node: starting XML-RPC server

[rospy.init][INFO] 2014-07-24 20:11:13,090: registered with master

[rospy.rosout][INFO] 2014-07-24 20:11:13,090: initializing /rosout core topic

[rospy.rosout][INFO] 2014-07-24 20:11:13,093: connected to core topic /rosout

[rospy.simtime][INFO] 2014-07-24 20:11:13,094: initializing /clock core topic

[rospy.simtime][INFO] 2014-07-24 20:11:13,096: connected to core topic /clock

[rosout][INFO] 2014-07-24 20:11:13,098: Loading model xml from ros parameter

[rosout][INFO] 2014-07-24 20:11:13,103: Waiting for service /gazebo/spawn_urdf_model

[rospy.internal][INFO] 2014-07-24 20:11:13,321: topic[/clock] adding connection to [http: //samper-MacBookPro:44259/], count 0

[rospy.internal][INFO] 2014-07-24 20:11:13,363: topic[/rosout] adding connection to [/rosout], count 0

[rosout][INFO] 2014-07-24 20:11:13,406: Calling service /gazebo/spawn_urdf_model

[rosout][INFO] 2014-07-24 20:11:14,467: Spawn status: SpawnModel: Successfully spawned model

[rospy.core][INFO] 2014-07-24 20:11:14,470: signal_shutdown [atexit]

[rospy.internal][INFO] 2014-07-24 20:11:14,477: topic[/rosout] removing connection to /rosout

[rospy.internal][INFO] 2014-07-24 20:11:14,477: topic[/clock] removing connection to http: //samper-MacBookPro:44259/

[rospy.impl.masterslave][INFO] 2014-07-24 20:11:14,477: atexit


Originally posted by Samper-Esc on ROS Answers with karma: 50 on 2014-07-24

Post score: 0


Original comments

Comment by tungsten on 2020-04-04:
did you have the answer

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Check the log files and show us the output.

sudo cat /home/samper/.ros/log/e4873b52-135d-11e4-bbd0-109add68f52e/spawn_turtlebot_model-4.log


Originally posted by DevonW with karma: 644 on 2014-07-25

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.