0
$\begingroup$

Rosanswers logo

Hi all and thanks for checking this out.

I have made a MoveIT! package using my urdf and went through the Setup Assistant tabs accordingly. After launching my robot I can motion plan and incorporate a scene object to be planned around, but the Global Status is giving me this error. I believe it has to do with the virtual joint set up but I'm not entirely sure.

No tf data. Actual error: Fixed Frame [base_link] does not exist

The base_link is the first link in my robot and the child of the virtual joint. When I add the TF display to Rviz and expand it, it's empty. This is preventing me from using rostopic echo /tf (where, right now, the output is a repeating empty Transform [] ) and also using rosbag record which I would like to use to record some simple paths for playback later.

Can someone tell me if this is in fact a virtual joint error or perhaps somewhere else I need to be looking? I am new to ROS so any links would be appreciated.

Respectfully,

Jordan


Originally posted by JoSo on ROS Answers with karma: 120 on 2014-07-17

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The solution for me was to declare both the parent frame and child frame as base_link in the SRDF.

<virtual_joint name="fixed_frame" type="fixed" parent_frame="base_link" child_link="base_link" />

This removed the Global Status error, now saying "OK" and the TF tree is populated! Moving on to bigger and harder things


Originally posted by JoSo with karma: 120 on 2014-07-17

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.