0
$\begingroup$

Rosanswers logo

I installed ros-hydro-openni-launch to my Odroid-U3. When I ran

roslaunch openni_launch openni.launch

it successfully streams as I can see the topics send average at 30 fps via the command

rostopic hz /camera/rgb/image_rect_color

However, once I subscribe also to

rostopic hz /camera/depth_registered/hw_registered/image_rect_raw

Both of the subscribers do not receive any more images as shown below..

Is this a bug? I also downloaded the latest commit of openni_launch and openni_camera in the github. But it was still the same... But they DO WORK alone. But subscribing to both of them fails....

image description


Originally posted by Xegara on ROS Answers with karma: 52 on 2014-07-08

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Looking at Openni.launch shows:

  <!-- Use OpenNI's factory-calibrated depth->RGB registration? -->
  <arg name="depth_registration" default="false" />

meaning you need to instead run

roslaunch openni_launch openni.launch depth_registration:=true

Although you are reporting that depth_registration works without setting that argument to be true, which is odd. Regardless maybe this will fix the issue? worth a shot...


Originally posted by ahubers with karma: 301 on 2014-08-05

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.