0
$\begingroup$

Rosanswers logo

Now that I have pocketsphinx running well, I am launching it with a number of other nodes. The basic pocketsphinx program prints many "INFO:" statements as it processes the voice input. This makes any messages printed by my other nodes unusable since they scroll off the screen rapidly.

Not using "output="screen" when recognizer.py is launched only stops the messages from recognizer.py, not from pocketsphinx.

Can anyone tell me how to stop these messages?

Thanks, Alex


Originally posted by Alex Brown on ROS Answers with karma: 176 on 2014-07-08

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Try playing with the logfn parameter:

E.g. from http://stackoverflow.com/questions/17825820/how-do-i-turn-off-e-info-in-pocketsphinx:

pocketsphinx_continuous -logfn /dev/null

Or write to file:

pocketsphinx_continuous -logfn [file]

In python (what ros pocketsphinx is using), from https://mattze96.safe-ws.de/blog/?p=640:

self.asr.set_property('logfn', '/dev/null') 

Originally posted by Kristof with karma: 141 on 2015-02-15

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by vikz91 on 2016-01-06:
This worked.. For windows Users, use pocketsphinx_continuous -logfn NUL

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.