0
$\begingroup$

Rosanswers logo

This is different from the solutions and questions that are already asked. I even tried to fix this with the already existing solutions although there differed by the "/opt/ros/hydro/lib/librviz.so: undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEEb" part of the error message.

The whole cmd line says:

developer@haf:~/catkin_ws$ rosrun rviz rviz [ INFO] [1404305441.695792813]: rviz version 1.10.16 [ INFO] [1404305441.695862492]: compiled against OGRE version 1.7.4 (Cthugha) /opt/ros/hydro/lib/rviz/rviz: symbol lookup error: /opt/ros/hydro/lib/librviz.so: undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEEb developer@haf:~/catkin_ws$


Originally posted by aboosaa on ROS Answers with karma: 11 on 2014-07-02

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I saw something similar recently. Try upgrading your installed versions of roslib and rviz to the latest versions:

sudo apt-get install ros-hydro-rviz ros-hydro-roslib

Originally posted by ahendrix with karma: 47576 on 2014-07-02

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by McMurdo on 2014-07-03:
Also, doing a dist-upgrade helps most often.

Comment by Dani C on 2015-02-18:
Thanks Austin!

sudo apt-get install ros-hydro-roslib

worked for me

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.