0
$\begingroup$

Rosanswers logo

Hi all,

When I run nao_driver, either in a simulator or on a nao robot (from my remote PC), I get this error:

Traceback (most recent call last): File "/home/jonfeme/nao_ws/src/nao_robot/nao_driver/nodes/nao_camera.py", line 156, in naocam = NaoCam() File "/home/jonfeme/nao_ws/src/nao_robot/nao_driver/nodes/nao_camera.py", line 84, in init if not self.cim.setURL( calibration_file ): File "/opt/ros/hydro/lib/python2.7/dist-packages/camera_info_manager/camera_info_manager.py", line 376, in setURL if parseURL(resolveURL(url, self.cname)) >= URL_invalid: File "/opt/ros/hydro/lib/python2.7/dist-packages/camera_info_manager/camera_info_manager.py", line 514, in resolveURL dollar = url.find('$', rest) AttributeError: 'NoneType' object has no attribute 'find' [nao_camera-8] process has died [pid 4000, exit code 1, cmd /home/jonfeme/nao_ws/src/nao_robot/nao_driver/nodes/nao_camera.py --pip=127.0.0.1 --pport=9559 __name:=nao_camera __log:=/home/jonfeme/.ros/log/cf9cdbf2-e55e-11e3-a9ca-000c29578851/nao_camera-8.log]. log file: /home/jonfeme/.ros/log/cf9cdbf2-e55e-11e3-a9ca-000c29578851/nao_camera-8*.log

I cannot use nao_camera. I installed ros-hydro-info-manager-py, but I have still the same problem. The same happens with nao_speech.py.

I have Naoqi version 1.14.5, the other nodes work fine, but camera and speech not.

I will be grateful for any help.

Thank you very much


Originally posted by JonathanAI on ROS Answers with karma: 41 on 2014-05-26

Post score: 0


Original comments

Comment by Vincent Rabaud on 2014-05-27:
what do you launch from the command line ? Do you set NAO_IP and roslaunch the nao_camera.launch ?

Comment by JonathanAI on 2014-05-27:
Yes. I launch NAO_IP= roslaunch nao_driver nao_driver.launch force_python:=true

I also included the nao_camera node in the nao_driver.launch

All nodes are available, excepting nao_camera, nao_speech and nao_tactile.

Thank you

Comment by Vincent Rabaud on 2015-05-09:
Please update to the latest code that should have handled those issues.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I have the same problem on Hydro and NaoQI 1.12.5 , nao_tactile is dying when launching nao_driver with this error

Exception TypeError: "in method 'module_getName', argument 1 of type 'AL::module *'" in <bound method NaoTactile.__del__ of <__main__.NaoTactile;  >> ignored

nao_speech is available though, and I can publish to /speech topic. However, nao_camera is not working, I can't launch the process, because it's dying after throwing exception

Traceback (most recent call last):
File "/opt/ros/hydro/lib/nao_driver/nao_camera.py", line 162, in <module>
    rospy.logerr('Something went wrong: %s' % (e.strerrror) )

I have managed to find the place, and it's throwing it on:

    self.nameId = self.camProxy.subscribe("rospy_gvm", self.resolution, self.colorSpace, self.fps)

Any ideas why that could happen, I am launching it with

PYTHONPATH=/opt/ros/hydro/lib/python2.7/dist-packages:/home/asiron/software/naoqi/lib:/home/asiron/software/naoqi/python
LD_LIBRARY_PATH=/opt/ros/hydro/lib:/home/asiron/software/naoqi/lib

Originally posted by asiron with karma: 26 on 2014-06-04

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by asiron on 2014-06-04:
Problem solved itself too, I don't know why but launch script was not reading properly ip address from NAO_IP env variable, and was crashing for this, now everything works

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.