0
$\begingroup$

Rosanswers logo

Hello,

To start I am new to both Ubuntu and ROS.

I am trying to follow the installation guides but am getting bogged down in permissions errors. I installed and removed ROS Indigo once already because I couldn't access the package files for whatever reason.

Now I received this error while running "rosdep update" (step 1.5 of indigo installation instructions)

daver@DSRUbuntu:~$ rosdep update reading in sources list data from /etc/ros/rosdep/sources.list.d

ERROR: Rosdep experienced an error: [Errno 13] Permission denied: '/home/daver/.ros/rosdep/sources.cache' Please go to the rosdep page [1] and file a bug report with the stack trace below. [1] :

rosdep version: 0.10.27

Traceback (most recent call last): File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 121, in rosdep_main exit_code = _rosdep_main(args) File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 277, in _rosdep_main return _no_args_handler(command, parser, options, args) File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 285, in _no_args_handler return command_handlerscommand File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 456, in command_update error_handler=update_error_handler) File "/usr/lib/pymodules/python2.7/rosdep2/sources_list.py", line 423, in update_sources_list retval.append((source, write_cache_file(sources_cache_dir, source.url, rosdep_data))) File "/usr/lib/pymodules/python2.7/rosdep2/sources_list.py", line 492, in write_cache_file os.makedirs(source_cache_d) File "/usr/lib/python2.7/os.py", line 157, in makedirs mkdir(name, mode) OSError: [Errno 13] Permission denied: '/home/daver/.ros/rosdep/sources.cache'

I've tried changing the root folder permissions but it's not applying correctly... I received similar errors on my previous installation attempt (not at this step, but later) and I was able to re-route the temporary cache files but I don't think that applies here.

Any suggestions would be sincerely appreciated.


Originally posted by DSRadin on ROS Answers with karma: 1 on 2014-05-16

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Delete the .ros ROS folder with sudo (make sure you're not deleting something useful) and rerun rosdep update - NO SUDO HERE!


Originally posted by dornhege with karma: 31395 on 2014-05-16

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by DSRadin on 2014-05-16:
Thanks for the reply dornhege - unfortunately it doesn't seem to have worked. Again, I'm showing my ignorance but I couldn't delete /home/daver/.ros achieving the error;

daver@DSRUbuntu:~$ sudo rm -f /home/daver/.ros [sudo] password for daver: rm: cannot remove ‘/home/daver/.ros’: Is a directory

followed shortly by the same error as before:

daver@DSRUbuntu:~$ sudo rm -f /home/daver/.ros/ros daver@DSRUbuntu:~$ rosdep update reading in sources list data from /etc/ros/rosdep/sources.list.d

ERROR: Rosdep experienced an error: [Errno 13] Permission denied: '/home/daver/.ros/rosdep/sources.cache'

Furthermore, I can't actually find this directory in the file explorer. I'm very confused about what is actually going on here.

Comment by jarvisschultz on 2014-05-16:
You can't see the directory in the file explorer because its name starts with ".", meaning it is hidden. Try pushing Ctrl+h in the file explorer (nautilus) to toggle hidden file visibility. The other error "...is a directory..." means you need to add "-r" to rm to indicate "recursive" delete.

Comment by jarvisschultz on 2014-05-16:
So command would be sudo rm -rf /home/daver/.ros @dornhege is correct... be careful when running commands like this.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.